Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000707Core InformTablespublic2011-07-19 14:382014-05-07 07:34
Reporterkoo5 
Assigned Tograham 
PrioritynormalSeverityseriousReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSLinuxOS VersionAny
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000707: listed in and corresponding fails with indexed text
Descriptionwhen column type is set to indexed text, corresponding to and listed in fails
Minimal Source Text To Reproduce
"Melon" by kook.

The forum is a room.

table of arguments
nname (indexed text)	vvalue (indexed text)
"entry"	"lost"

When play begins:
	unless "entry" is a nname listed in the table of arguments:
		say the vvalue corresponding to a nname of "entry" in the table of arguments;
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships

-  Notes
(0001222)
koo5 (reporter)
2011-07-19 15:27

in a more complex code, it seems to fail with (text) too
(0001223)
koo5 (reporter)
2011-07-19 16:49

i see, the values have to be of same kind, text <> indexed text
(0001224)
Victor Gijsbers (reporter)
2011-07-20 03:41

Note that this source does work:

===
"Lost" by Victor Gijsbers

The forum is a room.

table of arguments
nname (indexed text) vvalue (indexed text)
"entry" "lost"

Textmatch is indexed text that varies.

When play begins:
now textmatch is "entry";
if textmatch is a nname listed in the table of arguments:
say the vvalue corresponding to a nname of textmatch in the table of arguments.
===

What is happening is that Inform 7 believes that "entry" is text, and doesn't match "entry" as indexed text.

Not certain whether that is a bug or intended behaviour, but it certainly is confusing.
(0001225)
koo5 (reporter)
2011-07-20 04:53

thanks Victor
(0002281)
graham (administrator)
2014-01-12 13:39

The unification of text and indexed text makes this moot, but anyway correct code is now generated.

- Issue History
Date Modified Username Field Change
2011-07-19 14:38 koo5 New Issue
2011-07-19 15:27 koo5 Note Added: 0001222
2011-07-19 16:49 koo5 Note Added: 0001223
2011-07-20 03:41 Victor Gijsbers Note Added: 0001224
2011-07-20 04:53 koo5 Note Added: 0001225
2011-07-26 00:04 jmcgrew Status new => acknowledged
2011-07-26 08:56 EmacsUser Status acknowledged => confirmed
2014-01-12 13:39 graham Note Added: 0002281
2014-01-12 13:39 graham Status confirmed => resolved
2014-01-12 13:39 graham Resolution open => fixed
2014-01-12 13:39 graham Assigned To => graham
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:34 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker