Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000703Core InformAssertions and creationspublic2011-07-18 08:452014-05-07 07:34
ReporterVictor Gijsbers 
Assigned Tograham 
PrioritynormalSeveritycriticalReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSWindowsOS Version7
Product Version 
Target VersionFixed in Version6L02 
Summary0000703: Internal error in Memory.w when defining a kind of value through a table
DescriptionThe code below results in the following error:

===
An internal error has occurred: attempt to retrieve wrong pointer type as instance. The current sentence is 'Some achievements are defined by the Table of Achievements' ; the error was detected at line 726 of "Chapter 2/Memory.w". This should never happen, and I am now halting in abject failure.
===

The code is probably illegal, since I'm reusing a variable name as the name for a value, but abject failures "should never happen". :)
Minimal Source Text To Reproduce
Church is a room.

best defence is a number that varies.

Achievement is a kind of value. Some achievements are defined by the Table of Achievements.

Table of Achievements
achievement
best defence
TagsNo tags attached.
Effect(critical) Compiler reports internal error
Attached Files

- Relationships
has duplicate 0000923closed Internal error for an activity variable which shadows a global variable 

-  Notes
(0001340)
graham (administrator)
2011-10-09 01:12

I suppose all bugs are self-inflicted, but this one especially so. Inform was issuing a problem message, but also wrote a little internal stuff to the debugging log; except that the logging code, hardly ever used, referred to the internal representation of local variables used until mid-2010 but then dropped. Anyway, fixed; Inform does indeed object to the re-use of the name in this way.

- Issue History
Date Modified Username Field Change
2011-07-18 08:45 Victor Gijsbers New Issue
2011-07-21 15:26 EmacsUser Status new => confirmed
2011-08-16 18:23 EmacsUser Summary Internal error in Memroy.w when defining a kind of value through a table => Internal error in Memory.w when defining a kind of value through a table
2011-10-09 01:12 graham Note Added: 0001340
2011-10-09 01:12 graham Status confirmed => resolved
2011-10-09 01:12 graham Resolution open => fixed
2011-10-09 01:12 graham Assigned To => graham
2012-05-23 16:34 EmacsUser Relationship added has duplicate 0000923
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:34 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker