Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000700Core InformUnderstandingpublic2011-07-15 11:432014-05-07 07:33
ReporterEmacsUser 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.6
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000700: Parse Token Letter D assumes that the match_length words that were matched begin at oops_from
DescriptionThe first test case in the attached source text causes this code
- - - -
    ! The following moves the word marker to just past the named object...
    wn = oops_from + match_length;
- - - -
from the end of Parse Token Letter D to run with oops_from set to 3 (for ``shoe'') and match_length set to 2 (because the shoe's custom parse_name backtracked one word to match the numeric property as well as ``shoe''). Hence, the parser looks for the preposition ``to'' one word too late, as demonstrated by the second test case being accepted.
Minimal Source Text To Reproduce
There is a room.
Here is a thing called the shoe.
Here is a person called Sam.
The shoe has a number called the flop.
The flop of the shoe is two.
Understand the flop property as describing the shoe.
Test me with "show two shoe to sam / show two shoe filler to sam".
Additional InformationFrom http://www.intfiction.org/forum/viewtopic.php?f=7&t=2817. [^]
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships

-  Notes
(0002504)
graham (administrator)
2014-02-15 06:08

Oops indeed: it should be match_from, not oops_from.

- Issue History
Date Modified Username Field Change
2011-07-15 11:43 EmacsUser New Issue
2011-07-15 11:46 EmacsUser Description Updated View Revisions
2011-07-26 00:03 jmcgrew Assigned To => jmcgrew
2011-07-26 00:03 jmcgrew Status new => acknowledged
2013-03-30 02:11 jmcgrew Assigned To jmcgrew =>
2013-03-30 02:11 jmcgrew Status acknowledged => confirmed
2014-02-15 06:08 graham Note Added: 0002504
2014-02-15 06:08 graham Status confirmed => resolved
2014-02-15 06:08 graham Resolution open => fixed
2014-02-15 06:08 graham Assigned To => graham
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker