Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000698Core InformUnderstandingpublic2011-07-15 11:342014-05-07 07:34
ReporterEmacsUser 
Assigned Tojmcgrew 
PrioritynormalSeveritycriticalReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.6
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000698: Internal error when understanding a non-EO property as describing too broad a class of things
Description- - - -
Problem. An internal error has occurred: non-EO property. The current sentence is 'Understand the flop property as describing a thing' ; the error was detected at line 144 of "Chapter 17/Either-Or Properties.w". This should never happen, and I am now halting in abject failure.
- - - -

Perhaps the error should have been

- - - -
Problem. You wrote 'Understand the flop property as describing a thing' : but that property is not allowed for the thing or kind in question, just as (ordinarily) 'understand the open property as describing a device' would not be allowed because it makes no sense to call a device 'open'.
 See the manual: 16.15 > Understanding things by their properties
- - - -
Minimal Source Text To Reproduce
There is a room.
Here is a thing called the shoe.
The shoe has a number called the flop.
Understand the flop property as describing a thing.
TagsNo tags attached.
Effect(critical) Compiler reports internal error
Attached Files

- Relationships

-  Notes
(0001343)
graham (administrator)
2011-10-09 05:33

Fixed. (Though the supplied source text is actually incorrect, because the number property belongs only to the shoe, not to things in general, as would be needed to give effect to the Understand sentence.)

- Issue History
Date Modified Username Field Change
2011-07-15 11:34 EmacsUser New Issue
2011-07-26 00:02 jmcgrew Assigned To => jmcgrew
2011-07-26 00:02 jmcgrew Status new => acknowledged
2011-10-09 05:33 graham Note Added: 0001343
2011-10-09 05:33 graham Status acknowledged => resolved
2011-10-09 05:33 graham Resolution open => fixed
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:34 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker