Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000692Gnome Inform application[IDEs] Installing Extensionspublic2011-07-07 19:002014-05-07 07:40
Reportermaabaum 
Assigned Topchimento 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86-64OSOpenSUSE LinuxOS Version11.4
Product Version 
Target VersionFixed in Version6L02 
Summary0000692: IDE fails to recognize Inform7 extensions when asked to install one
DescriptionCompiled gnome-inform7 from the trunk code, most recently on 7 JUL 2011. The program appears to compile and install properly. Two things are anomalous:

1. The eyecandy graphics are missing from the opening dialogue (new project-existing project-last project).

2. Attempts to install an extension file fail with the message (e.g.):
---------8<----------------------------
The file '/home/michael/Downloads/Computers.i7x' does not seem to be an extension. Extensions should be saved as UTF-8 text format files, and should start with a line of one of these forms:

<Extension> by <Author> begins here.
Version <Version> of <Extension> by <Author> begins here.
---------8<----------------------------
This obviously was tried with Emily Short's Computers, but others fail as well. The extension file itself is correct and if manually added to the proper inform directory, it will include and compile properly. Only the install routine fails to recognize it.

Minimal Source Text To Reproduce
n/a
Tagsextensions, openSUSE
Attached Files

- Relationships

-  Notes
(0001216)
maabaum (reporter)
2011-07-08 09:10

I've verified that this also happens with the earlier distribution of openSUSE:
Linux 2.6.34.8-0.2-desktop x86_64, openSUSE 11.3 (x86_64). Different machine, same architecture. Different extension file (Secret Doors by Andrew Owen version 1).
In this test, however, although the serious problem (failure to install new extensions) persists, the trivial problem (graphic elements don't display in opening dialogue) goes away. Kind of odd.

maab
(0001218)
maabaum (reporter)
2011-07-12 18:30

In the code file app.c, function is_valid_extension, at line 336 or thereabouts:

if(!g_regex_match(app->regices[I7_APP_REGEX_EXTENSION], text, 0, &match))

the value of app->regices[I7_APP_REGEX_EXTENSION] looks like it might be an empty string which perhaps causes this function to return FALSE?

maab
(0001229)
maabaum (reporter)
2011-07-22 17:43

I am recommending that this be severely modified and downgraded in severity to "mildly annoying" because the main problem in my build is that I absent-mindedly built the program in the "trunk" hierarchy instead of "tags/6G60". In the latter build, the problem with installing extensions goes away. I really need to drink more coffee. Or just drink more.
OTOH, the minor irritant, that the graphic background goes missing from the welcome dialog, is still a (minor) issue.
(0001238)
pchimento (developer)
2011-08-04 12:02

Can't reproduce the opening graphic issue, but the extension recognition problem is solved.

- Issue History
Date Modified Username Field Change
2011-07-07 19:00 maabaum New Issue
2011-07-08 09:10 maabaum Note Added: 0001216
2011-07-08 09:11 maabaum Tag Attached: extensions
2011-07-08 09:11 maabaum Tag Attached: openSUSE
2011-07-12 18:30 maabaum Note Added: 0001218
2011-07-22 17:43 maabaum Note Added: 0001229
2011-07-23 01:57 pchimento Assigned To => pchimento
2011-07-23 01:57 pchimento Status new => assigned
2011-07-23 01:58 pchimento Severity serious => mild
2011-07-23 01:58 pchimento Product Version 6G60 =>
2011-08-04 12:02 pchimento Note Added: 0001238
2011-08-04 12:02 pchimento Status assigned => resolved
2011-08-04 12:02 pchimento Resolution open => fixed
2014-05-07 07:40 jmcgrew Fixed in Version => 6L02
2014-05-07 07:40 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker