Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000069Mac OS X Inform application[IDEs] User Interfacepublic2010-06-18 17:302010-07-01 23:59
Assigned Toahunter 
Platformx86OSMac OS XOS Version10.5
Product Version6E59 
Target VersionFixed in Version6E72 
Summary0000069: Find dialog closes after switching to a different search string
DescriptionSteps to reproduce:

1. Start Inform
2. Click on ``Start a new project...''
3. Select ``Inform 7 -> New Project''
4. Click on ``Next''
5. Browse to file location
6. Click ``Create''
7. Open the find dialog
8. Enter some text, say `a'
9. Click ``Next'' (it is not necessary for the text to be findable)
10. Enter some other text, say `b'
11. Click on the down arrow by the search string, to open the drop-down
12. Click on the original text (`a' in this case)
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
ahunter (developer)
2010-06-20 09:24

Hmm, the standard OS X find box hides itself when the user types some text and hits enter, but doesn't when you do pretty much anything else.

Unfortunately, selecting something from a Cocoa drop down also generates the same event (despite being specifically set to 'send on Enter only'), with no way to determine that the action results from the user moving the mouse. I'd class this as a bug in Cocoa: there's already an action type for 'any editing' and I can't see what user would equate clicking an entry in the drop down as being the same thing as typing something in and pressing enter.

Due to the way this is implemented, I can't mirror the standard find box behaviour. On balance, I think it's less annoying for hitting Enter to leave the find box present than it is to have it randomly disappear when choosing from the drop down, so I'll pick the least broken alternative.
ahunter (developer)
2010-06-20 09:45

Should be fixed in UI build 2751. [^]

- Issue History
Date Modified Username Field Change
2010-06-18 17:30 EmacsUser New Issue
2010-06-18 17:37 jmcgrew Status new => acknowledged
2010-06-19 12:42 jmcgrew Status acknowledged => confirmed
2010-06-19 14:20 jmcgrew Priority low => normal
2010-06-20 07:29 graham Assigned To => ahunter
2010-06-20 07:29 graham Status confirmed => assigned
2010-06-20 09:24 ahunter Note Added: 0000084
2010-06-20 09:45 ahunter Note Added: 0000088
2010-06-20 09:45 ahunter Status assigned => resolved
2010-06-20 09:45 ahunter Resolution open => fixed
2010-07-01 23:08 jmcgrew Fixed in Version => 6E72
2010-07-01 23:08 jmcgrew Status resolved => closed
2010-07-01 23:20 jmcgrew Fixed in Version => 6E72
2010-07-01 23:59 jmcgrew Product Version => 6E59

Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker