Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000689Documentation, Examples, and Web SiteExamplespublic2011-07-05 04:112014-05-07 07:38
ReporterScooter 
Assigned Toemshort 
PrioritynormalSeveritymildReproducibilitysometimes
StatusclosedResolutionfixed 
Platformx86OSWindowsOS Version7
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000689: Hatless 3 example leaves one character hatless
DescriptionRunning the "Hatless 3" example in Chapter 8.11 of basic documentation reveals flaw in some routine, possibly randomization, possibly another. Caveat - this user (Scooter) is new to Inform, but an old hand at QA.
Minimal Source Text To Reproduce
"Hatless 3" scenario of Chapter 8, section 11 in documentation. See Additional Info for 
steps to reproduce.
Additional Information1) Navigate to Chapter 8.11 in documentation.
2) Place "Hatless 3" scenario from documentation into Source Text pane.
3) Click "Go" button
4) In "Game" pane, type "Test Me" followed by <ENTER> key.
5) Repeat steps (3) and (4) several times.

RESULT: Sometimes all four characters wear hats. Often only 3 characters wear hats.
EXPECT: All four characters should wear hats in EVERY run.

THEORY: Error in Randomization routines, and/or Looping routines, and/or object references?
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0001212)
mattweiner (reporter)
2011-07-05 09:07

The problem, if it is a problem, is in the line "now the item is worn by a random hatless person"; there's nothing that prevents that from putting the hat on the player. Or maybe that's expected behavior. Anyway, take inventory when only three of the NPCs are wearing hats and you'll find that you're wearing one.
(0001226)
EmacsUser (manager)
2011-07-21 14:39

As noted, the player is eligible to receive a hat, so there is no bug in the Inform routines. If you think the example is unclear on this point, we could convert this report to a documentation bug.
(0001230)
mattweiner (reporter)
2011-07-25 16:41

I think it's a documentation bug -- the "Hatless" examples start "Suppose we want a game in which each scenario starts with the characters wearing hats -- randomly passed out." Which suggests that each character, or at least each NPC, will wear a hat. And the fact that there are four hats and four NPCs suggests that each NPC is intended to get a hat.

Maybe there isn't any outright falsehood in the documentation as it stands, but I think it is confusing. (I had to start doing showme for the hats before I realized that the PC was wearing one.)

- Issue History
Date Modified Username Field Change
2011-07-05 04:11 Scooter New Issue
2011-07-05 09:07 mattweiner Note Added: 0001212
2011-07-21 14:39 EmacsUser Note Added: 0001226
2011-07-21 14:39 EmacsUser Status new => feedback
2011-07-25 16:41 mattweiner Note Added: 0001230
2011-07-26 00:06 jmcgrew Project Core Inform => Documentation, Examples, and Web Site
2011-07-26 00:09 jmcgrew Severity serious => mild
2011-07-26 00:09 jmcgrew Status feedback => acknowledged
2011-07-26 00:09 jmcgrew Category Phrases and functional programming => Examples
2011-07-26 00:09 jmcgrew Summary Hatless 3 example demonstrates flaw in randomization functionality => Hatless 3 example leaves one character hatless
2011-07-26 08:57 EmacsUser Status acknowledged => confirmed
2011-10-18 11:43 graham Assigned To => emshort
2011-10-18 11:43 graham Status confirmed => assigned
2014-01-25 10:05 graham Status assigned => resolved
2014-01-25 10:05 graham Resolution open => fixed
2014-05-07 07:37 jmcgrew Fixed in Version => 6L02
2014-05-07 07:38 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker