Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000687Documentation, Examples, and Web SiteExamplespublic2011-07-04 11:302014-05-07 07:38
Reporternorpan 
Assigned Toemshort 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000687: In Disenchantment Bay 12, a beverage is "openable" but open does not work on it
Description>open beer

*** Run-time problem P10: Since the warm beer is not allowed the property "open", it is against the rules to try to use it.


You open the warm beer.
Minimal Source Text To Reproduce
test first with "open beer"
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0001214)
norpan (reporter)
2011-07-07 08:29

Maybe the standard rules should add the check that opening something fails if it doesn't provide the "open" property. ditto for close.
(0001217)
soukie (reporter)
2011-07-09 00:20

The Disenchatment Bay example would have to add a sentence "A beverage can be open." for it to work. This is because the 'beverage' has been defined as a kind of thing, not a kind of container.

In my opinion, when the story defines something 'can be openable,' Inform could automatically give it the 'open' property too.

- Issue History
Date Modified Username Field Change
2011-07-04 11:30 norpan New Issue
2011-07-04 20:39 jmcgrew Priority low => normal
2011-07-04 20:39 jmcgrew Status new => acknowledged
2011-07-04 21:36 EmacsUser Status acknowledged => confirmed
2011-07-04 21:36 EmacsUser Category The Recipe Book => Examples
2011-07-07 08:29 norpan Note Added: 0001214
2011-07-09 00:20 soukie Note Added: 0001217
2011-10-18 11:40 graham Assigned To => emshort
2011-10-18 11:40 graham Status confirmed => assigned
2014-01-25 10:01 graham Status assigned => resolved
2014-01-25 10:01 graham Resolution open => fixed
2014-05-07 07:37 jmcgrew Fixed in Version => 6L02
2014-05-07 07:38 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker