Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000678Gnome Inform application[IDEs] Skein and Transcriptpublic2011-06-21 04:232015-05-10 17:47
ReporterVictor Gijsbers 
Assigned Topchimento 
PrioritynormalSeverityseriousReproducibilityalways
StatusclosedResolutionfixed 
Platformx64OSLinuxOS VersionAny
Product Version6G60 
Target VersionFixed in Version 
Summary0000678: Having a large skein causes massive slowdowns in the in-IDE interpreter
DescriptionWhen running my large WIP, the in-IDE game experienced incredible delays. It printed out the text fairly quickly, but then I had to sit back and wait for the command prompt to appear. This could take 10, 20, 30 seconds. It only happened when a command prompt has to be printed: if you give five commands at one prompt, it will print out the answers to all five commands without delay... and then the waiting starts.

The problem was solved by radically trimming the Skein. I suspect that having a very large skein will always create this problem (at least on my system), but this is a little hard to test right now. (I have no great desire to restart a game several hundred times to type in new strings of commands.) This also means that it is hard for me to test whether the problem appears in all games, or whether it has something to do with this specific game.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0001202)
Victor Gijsbers (reporter)
2011-06-21 04:25
edited on: 2011-06-21 04:27

Additional info: I chose 6F95, because the menu wouldn't allow me to choose 6G60. I am using 6G60, 64-bit, on a fresh installation of Ubuntu 11.04. I had the same problem under Ubuntu 10.10.

Also, switching from Glulxe to Git has no effect. I don't think any of the options in the Preferences menu have an effect.

(0001203)
EmacsUser (manager)
2011-06-22 14:36

Confirmed. Looks like the delay is in i7_skein_draw.
(0001240)
pchimento (developer)
2011-08-06 08:56

Okay, I didn't have a game with a really _huge_ Skein to test it on, but I had one that was large enough that the delay was about 2 sec. per command. I managed to speed it up by about 20 times, and do the operations in idle time - so you shouldn't notice any slowdowns or lockups anymore.

If somebody could test a build from git master on a project with a gargantuan Skein, that would be a nice plus - or at least send me a copy of a game to test. But for now I'm closing the bug.
(0001242)
EmacsUser (manager)
2011-08-10 23:15

I see hardly any delay now, so I can verify the fix. I'll e-mail you my test case.
(0003743)
jmcgrew (administrator)
2015-05-10 17:47

Closing all resolved issues from 2014 and earlier.

- Issue History
Date Modified Username Field Change
2011-06-21 04:23 Victor Gijsbers New Issue
2011-06-21 04:25 Victor Gijsbers Note Added: 0001202
2011-06-21 04:27 Victor Gijsbers Note Edited: 0001202 View Revisions
2011-06-21 13:57 jmcgrew Status new => acknowledged
2011-06-21 13:57 jmcgrew Platform x86 => x64
2011-06-21 13:57 jmcgrew Product Version 6F95 => 6G60
2011-06-22 14:36 EmacsUser Note Added: 0001203
2011-06-22 14:36 EmacsUser Reproducibility have not tried => always
2011-06-22 14:36 EmacsUser Status acknowledged => confirmed
2011-07-04 02:10 pchimento Assigned To => pchimento
2011-07-04 02:10 pchimento Status confirmed => assigned
2011-08-06 08:56 pchimento Note Added: 0001240
2011-08-06 08:56 pchimento Status assigned => resolved
2011-08-06 08:56 pchimento Resolution open => fixed
2011-08-10 23:15 EmacsUser Note Added: 0001242
2015-05-10 17:47 jmcgrew Note Added: 0003743
2015-05-10 17:47 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker