Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000661Core InformAssertions and creationspublic2011-05-18 03:482014-05-07 07:33
ReporterFuchsia tude 
Assigned Tograham 
PrioritynormalSeverityseriousReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSWindowsOS Version7
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000661: Compound sentence of new non-preposition assertion verbs will not compile
DescriptionAfter defining multiple new assertion verbs that are valid for an object, attempting to combine them in a single assertion sentence will not compile.

Moreover, the error message incorrectly claims that the same property is trying to be set, even though each verb relates to a different property and each phrase definition contains no word in common with the other.
Minimal Source Text To Reproduce
Sylvan relates one room to various rooms. The verb to be forestwise from implies the sylvan relation. 
The verb to lead forestwise to (he leads forestwise to) implies the reversed sylvan relation.
Buildwise relates one room to various rooms. The verb to be buildwise form implies the buildwise relation. 
The verb to run buildwise towards (he runs buildwise towards) implies the reversed buildwise relation.


Road is a room. Forest is a room. Building is a room. 
Forest is forestwise from Road, forestwise from Building.
Road leads forestwise to Forest. It runs buildwise towards Building. [compiles]
Road leads forestwise to Forest, runs buildwise towards Building. [does not compile]
Road leads forestwise to Forest and runs buildwise towards Building. [does not compile]
Additional InformationThis is the report produced by Inform 7 (build 6G60) on its most recent run through:


Problem. You wrote 'Road leads forestwise to Forest, runs buildwise to Building' : but this looks like a contradiction, because the same property seems to be being set in each of these sentences, but with a different outcome.
TagsNo tags attached.
Effect(serious) Compiler rejects valid code
Attached Files

- Relationships

-  Notes
(0001180)
EmacsUser (manager)
2011-05-23 09:07

The error message is correct; the trouble is Inform reading ``runs buildwise towards building'' as a room name, so that

- - - -
Forest is forestwise from Road, forestwise from Building.
- - - -

asserts ``forest sylvan-relation road,'' which is contradicted by the line

- - - -
Road leads forestwise to Forest, runs buildwise towards Building.
- - - -

asserting ``runs buildwise towards building sylvan-relation road'' (the sylvan relation is one-to-various).
(0002664)
graham (administrator)
2014-05-04 09:52

Inform's behaving correctly here (it doesn't allow multiple primary verbs in a sentence), but it now explains itself with a more helpful problem message.

- Issue History
Date Modified Username Field Change
2011-05-18 03:48 Fuchsia tude New Issue
2011-05-22 12:51 jmcgrew Status new => acknowledged
2011-05-23 09:07 EmacsUser Note Added: 0001180
2011-05-23 09:07 EmacsUser Status acknowledged => confirmed
2014-05-04 09:52 graham Note Added: 0002664
2014-05-04 09:52 graham Status confirmed => resolved
2014-05-04 09:52 graham Resolution open => fixed
2014-05-04 09:52 graham Assigned To => graham
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker