Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000644Core InformKinds and type checkingpublic2011-04-15 15:182014-05-07 07:34
ReporterEmacsUser 
Assigned Tograham 
PrioritynormalSeverityseriousReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.6
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000644: Kind from WI 21.1 cannot be used in a let phrase
DescriptionThe attached source provokes this problem message:
- - - -
Problem. In the sentence 'let foo be a phrase (phrase number -> (phrase number -> number)) -> nothing' , I was expecting to read a value, but instead found some text that I couldn't understand - 'a phrase (phrase number -> (phrase number -> number)) -> nothing'.
I was trying to match one of these phrases:

1. let (foo - a new name) be (a phrase ( phrase number -> ( phrase number -> number ) ) -> nothing - description of relations of values to values)
2. let (foo - a new name) be (a phrase ( phrase number -> ( phrase number -> number ) ) -> nothing - name of kind)
3. let (foo - a new name) be (a phrase ( phrase number -> ( phrase number -> number ) ) -> nothing - value)
4. let (foo - a temporary named value) be (a phrase ( phrase number -> ( phrase number -> number ) ) -> nothing - value)
This was what I found out:

foo = something unrecognised
a phrase (phrase number -> (phrase number -> number)) -> nothing = something unrecognised
- - - -

A similar error appears for
- - - -
There is a room.
When play begins:
let foo be a phrase (phrase number -> number) -> nothing.
- - - -
Minimal Source Text To Reproduce
There is a room.
When play begins:
	let foo be a phrase (phrase number -> (phrase number -> number)) -> nothing.
TagsNo tags attached.
Effect(serious) Compiler rejects valid code
Attached Files

- Relationships

-  Notes
(0001502)
graham (administrator)
2011-12-19 17:06

Fixed: an error in parsing the name, since this is a perfectly valid kind.

- Issue History
Date Modified Username Field Change
2011-04-15 15:18 EmacsUser New Issue
2011-04-23 20:31 jmcgrew Status new => acknowledged
2011-05-30 22:11 jmcgrew Status acknowledged => confirmed
2011-12-19 17:06 graham Note Added: 0001502
2011-12-19 17:06 graham Status confirmed => resolved
2011-12-19 17:06 graham Resolution open => fixed
2011-12-19 17:06 graham Assigned To => graham
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:34 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker