Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000064Core InformExtensionspublic2010-06-18 12:252010-07-01 23:07
Assigned Tograham 
Platformx86OSMac OS XOS Version10.6
Product Version6E59 
Target VersionFixed in Version6E72 
Summary0000064: Generalized conditions in text containing line breaks can cause I6 errors
DescriptionLiquid Handling wh ich worked under 5U92 no longer works with 6E59. It did no work with 5Z71 but since I got no feedback from any authors I was unaware of it.

I have sent copies of both Supplemental Actions which Liquid Handling requires and the Liquid handling extension to both Graham and Mark Musante.

Supplemental Actions works on5U92 and forward. Liquid Handling stopped working after 5U92.
Minimal Source Text To Reproduce
Home is a room. "[if a room is lit]Somewhere there's a light on.
[otherwise]The world is a dark place."
Additional InformationThe incompatibility with Liquid Handling results from this code:

  the description of an absorber usually is
  "Used in wiping up spilled liquids. [The noun] is [if absorber is unsoaked]dry.
  [otherwise]soaked with [list of things in the noun].[end if]".

That is valid I7 code, although it doesn't do what the author intended. Instead of checking the particular absorber being examined, it checks all absorbers in the game - and that generalized condition causes a Prop_* routine to be generated, with the description copied into a comment above it. But the line break in the description is copied into the comment, causing it to spill onto a non-comment line, which results in an I6 syntax error.
TagsNo tags attached.
Effect(critical) Inform 6 compiler reports errors for valid code
Attached Files

- Relationships

-  Notes
graham (administrator)
2010-06-18 15:55

Fixed. Interesting that nobody noticed this in 5Z71 - it must be that very few people type internal hard return characters in paragraphs of running prose, I suppose.

- Issue History
Date Modified Username Field Change
2010-06-18 12:25 Al New Issue
2010-06-18 14:07 jmcgrew Status new => confirmed
2010-06-18 14:07 jmcgrew Summary Liquid Handling no longer works with 6E59 => Generalized conditions in text containing line breaks can cause I6 errors
2010-06-18 14:07 jmcgrew Steps to Reproduce Updated View Revisions
2010-06-18 14:07 jmcgrew Additional Information Updated View Revisions
2010-06-18 15:55 graham Note Added: 0000047
2010-06-18 15:55 graham Status confirmed => resolved
2010-06-18 15:55 graham Resolution open => fixed
2010-06-18 15:55 graham Assigned To => graham
2010-06-19 14:20 jmcgrew Priority high => normal
2010-06-30 18:07 jmcgrew Fixed in Version => 6E72
2010-07-01 23:07 jmcgrew Status resolved => closed

Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker