Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000638Core InformAssertions and creationspublic2011-04-08 10:112014-05-07 07:33
ReporterChrisC 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSWindowsOS Version7
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000638: Defining facts about player before defining who player is discards those facts
DescriptionExcept for when it comes to ordering rules, I think the compiler should ideally be as agnostic to the order of lines in the source text as possible.

In this case, though, this seems even more clearly a bug: the author has defined certain facts about the player character, whom NI made assumptions about; on discovering that its assumptions were incorrect, rather than reevaluating, it simply discards those facts.

The watch, for example, is worn by "your former self", which surely should never happen unless the player becomes a different actor as the result of a "now" phrase during play.
Minimal Source Text To Reproduce
Park is a room. A blanket is an enterable supporter in the Park.

The player wears a watch. The player is on the blanket.

The player is a woman called Terry.
Additional InformationPark
You can see a blanket here.

>i
You are carrying nothing.

>showme watch
watch - thing
location: worn by your former self out of play
singular-named, improper-named; unlit, inedible, portable, wearable
printed name: "watch"
printed plural name: none
indefinite article: none
description: none
initial appearance: none
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships

-  Notes
(0002656)
graham (administrator)
2014-05-04 08:08

Surprisingly, it's a duplicate of 0001142; fixed.

- Issue History
Date Modified Username Field Change
2011-04-08 10:11 ChrisC New Issue
2011-04-23 20:27 jmcgrew Status new => acknowledged
2011-04-25 15:34 EmacsUser Status acknowledged => confirmed
2014-05-04 08:08 graham Note Added: 0002656
2014-05-04 08:08 graham Status confirmed => resolved
2014-05-04 08:08 graham Resolution open => fixed
2014-05-04 08:08 graham Assigned To => graham
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker