Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000636Core InformUnderstandingpublic2011-04-06 17:492014-05-07 07:34
ReporterEgon 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000636: Multiexcept lookahead
DescriptionIncomplete input which depends on a multiexcept token, such as a player typing INSERT COIN rather than INSERT COIN INTO VENDING MACHINE, produces "I didn't understand that sentence." rather than "What do you want to insert the coin in?", which is what library 6/11 produces. This probably affects multiinside tokens as well.

These changes to the L61127 patch seem to fix the problem:

if (wn > num_words) {
#Ifdef DEBUG;
if (parser_trace >= 2)
print " [Look-ahead aborted: prepositions missing]^";
#Endif;

- jump LineFailed;
+ jump EmptyLine;
}

.....

} until (line_ttype-->pcount ~= PREPOSITION_TT);

+ .EmptyLine;

! put back the non-preposition we just read

wn--;
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships
related to 0000963closedDavidG I6 Library Multiexcept lookahead 

-  Notes
(0001139)
EmacsUser (manager)
2011-04-15 15:33

Confirmed, though to be clear the output ``What do you want to insert the coin in?'' only appears if a ``does the player mean'' rule keeps Inform from choosing a second noun on its own.
(0001745)
DavidG (reporter)
2012-08-03 12:44

I would like to be assigned this bug since I am maintaining Inform6lib.
(0001746)
zarf (developer)
2012-08-04 11:56

As I understand it, this bug tracker has categories for the I6 compiler and the I6 code which is included in the I7 libraries and templates. It doesn't have a category for the I6 library as a standalone package.

I leave it up to the admins whether they want to add that category. But if they do, we'd want to fork this bug and track it separately for the I6-lib and I7-core categories. (Because (a) they're separate release streams with different maintainers, and (b) the code isn't identical so any fix needs to be tested separately in both environments.)
(0001748)
jmcgrew (administrator)
2012-08-04 22:25

I think the Inform 6 project is fine for reporting I6 library bugs. I've cloned this issue over there as 0000963 and assigned it to frotz; this one will remain for the I7 incarnation.
(0001749)
DavidG (reporter)
2012-08-04 22:30

Just in case anyone missed it, the Inform6lib git is up at https://github.com:DavidGriffith/inform6lib.git [^] for anyone who wants to see what I'm up to.
(0001750)
DavidG (reporter)
2012-08-04 23:17

The IF Archive must have a different version of parserm.h for version 6/11 because the patch listed at http://www.inform-fiction.org/patches/L61127.html [^] fails with the first hunk. I think I can identify the section that the first hunk wants to modify, but I'm having trouble making sense of the -c type diff. Could I get a unified diff against 6/11's parserm.h or better yet, a unified diff against parserm.h from the master branch at github?
(0001751)
jmcgrew (administrator)
2012-08-04 23:54

Try applying the other I6 library patches first, I think this patch depends on them.

As for context vs. unified diffs, just treat the "!" lines as a "-" of the line in the first context followed by a "+" of the line in the second context.
(0001752)
DavidG (reporter)
2012-08-05 00:16
edited on: 2012-08-05 22:03

I'm not so sure about the dependencies. The code I have on github includes all the patches for issues prior L61127 and both hunks fail. I'll just do it manually. (time passes). Okay, the patch is applied and commited as well as Egon's changes.

(0001769)
DavidG (reporter)
2012-08-05 22:05

I made a test program and confirmed that Egon's solution works. This bug can be closed now.
(0002314)
graham (administrator)
2014-01-18 16:22

Any change in this area makes some things better and other things worse, but I'm persuaded that this is mostly a gain, so I've accepted it.

- Issue History
Date Modified Username Field Change
2011-04-06 17:49 Egon New Issue
2011-04-12 23:54 jmcgrew Status new => acknowledged
2011-04-12 23:54 jmcgrew Priority low => normal
2011-04-15 15:33 EmacsUser Note Added: 0001139
2011-04-15 15:33 EmacsUser Status acknowledged => confirmed
2012-08-03 12:41 DavidG Issue Monitored: DavidG
2012-08-03 12:44 DavidG Note Added: 0001745
2012-08-04 11:56 zarf Note Added: 0001746
2012-08-04 22:17 jmcgrew Issue cloned 0000963
2012-08-04 22:17 jmcgrew Relationship added related to 0000963
2012-08-04 22:25 jmcgrew Note Added: 0001748
2012-08-04 22:30 DavidG Note Added: 0001749
2012-08-04 23:17 DavidG Note Added: 0001750
2012-08-04 23:54 jmcgrew Note Added: 0001751
2012-08-05 00:16 DavidG Note Added: 0001752
2012-08-05 00:47 DavidG Note Edited: 0001752 View Revisions
2012-08-05 01:16 DavidG Note Edited: 0001752 View Revisions
2012-08-05 01:23 DavidG Note Edited: 0001752 View Revisions
2012-08-05 01:24 DavidG Note Edited: 0001752 View Revisions
2012-08-05 22:03 DavidG Note Edited: 0001752 View Revisions
2012-08-05 22:05 DavidG Note Added: 0001769
2014-01-18 16:22 graham Note Added: 0002314
2014-01-18 16:22 graham Status confirmed => resolved
2014-01-18 16:22 graham Resolution open => fixed
2014-01-18 16:22 graham Assigned To => graham
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:34 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker