Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000633Core InformUnderstandingpublic2011-03-31 17:512014-05-07 07:33
Reportermikegentry 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSWindowsOS Version7
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000633: "does the player mean" not working with inserting action
DescriptionThe "does the player mean" rulebook does not seem to be firing when the action is inserting something into.
Minimal Source Text To Reproduce
The Kitchen is a room. 
A red apple is in the Kitchen.
A red tomato is in the Kitchen. 
The microwave oven is an open, unopenable container, in the kitchen.
The brick oven is an open, unopenable container, in the kitchen.
Does the player mean inserting the apple into something: it is likely.
Does the player mean inserting something into the brick oven: it is likely.
Additional InformationTranscript:


>get apple and tomato
red apple: Taken.
red tomato: Taken.

>put red in microwave
Which do you mean, the red tomato or the red apple?

>put tomato in oven
Which do you mean, the microwave oven or the brick oven?
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships
has duplicate 0000943closed Core Inform "Does the player mean" rule using relations compiled but ignored? 
related to 0000948closedgraham Documentation, Examples, and Web Site Request to increase the clarity of documentation in 16.21 

-  Notes
(0001123)
EmacsUser (manager)
2011-04-07 09:30
edited on: 2011-04-07 09:33

Adding the lines

- - - -
Does the player mean wearing the red apple:
    it is likely.
Does the player mean dropping the red apple:
    it is likely.
- - - -

seems to fix the first case (these verbs share the word ``put'' in their understand lines). Looking into it.

(0001124)
EmacsUser (manager)
2011-04-07 09:44

It looks like Inform sees the word ``put,'' and tries to parse the command as wearing (putting something on), then as dropping (putting down), then as inserting (putting into), etc. The first attempt with wearing succeeds up until the point where the word red is ambiguous, at which point the parser has not yet checked whether the rest of the input matches the understand line. It then jumps to disambiguation, and the other meanings of ``put'' remain untried.
(0001717)
EmacsUser (manager)
2012-07-19 16:08

There is a related feature request at http://inform7.uservoice.com/forums/57320-general/suggestions/3013510-allow-author-to-control-ordering-of-actions-in-i6-. [^]
(0001720)
otistdog (reporter)
2012-07-19 19:38

Bug 943 (http://inform7.com/mantis/view.php?id=943 [^]) is marked a duplicate of this one, but readers may wish to view that page for a potentially-applicable workaround strategy.
(0002506)
graham (administrator)
2014-02-15 07:34

I've made improvements to the parser such that neither of these bad cases happens, and both questions are unnecessary, but by pragmatic means rather than a completely new algorithm.

- Issue History
Date Modified Username Field Change
2011-03-31 17:51 mikegentry New Issue
2011-04-07 09:30 EmacsUser Note Added: 0001123
2011-04-07 09:30 EmacsUser Note Edited: 0001123 View Revisions
2011-04-07 09:33 EmacsUser Note Edited: 0001123 View Revisions
2011-04-07 09:44 EmacsUser Note Added: 0001124
2011-04-07 09:44 EmacsUser Status new => confirmed
2011-04-07 09:50 EmacsUser Category Rules and rulebooks => Understanding
2012-07-19 16:07 EmacsUser Relationship added has duplicate 0000943
2012-07-19 16:08 EmacsUser Note Added: 0001717
2012-07-19 19:38 otistdog Note Added: 0001720
2012-07-21 05:30 EmacsUser Relationship added related to 0000948
2012-08-10 20:59 otistdog Issue Monitored: otistdog
2014-02-15 07:34 graham Note Added: 0002506
2014-02-15 07:34 graham Status confirmed => resolved
2014-02-15 07:34 graham Resolution open => fixed
2014-02-15 07:34 graham Assigned To => graham
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker