Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000063Core InformExtensionspublic2010-06-18 09:302010-07-01 23:07
ReporterEmacsUser 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.4
Product Version6E59 
Target VersionFixed in Version6E72 
Summary0000063: Installing a poorly named extension causes all projects to fail compilation with a cryptic error
DescriptionWhen an extension name includes a full stop, Inform will not complain in the index. However, on compilation of any project, even one not using the extension, it produces the following error:

Problem. You wrote <no text>: but I can't find that extension, which seems not to be installed. (You can get hold of extensions which people have made public at the Inform website.)

This behavior could be a show-stopper for someone, so I've marked it as serious, even though the category is ``Error message is badly worded.''
Minimal Source Text To Reproduce
The file Y.i7x
- - - -
Version 1 of Y.i7x by John Doe begins here.
Y.i7x ends here.
- - - -


The source code.
- - - -
X is a room.
- - - -
TagsNo tags attached.
Effect(mild) Compiler accepts invalid code
Attached Files

- Relationships
related to 0000238closedemshort Documentation, Examples, and Web Site Restrictions on initials in extension author names are not clear from WI 25.3 

-  Notes
(0000040)
jmcgrew (administrator)
2010-06-18 10:41

Changed severity and effect: I'm trying not to deviate from the severity guidelines, but I think this is plausibly a "compiler accepts invalid code" issue since the manual warns against using "unusual letters in titles" (and periods are not allowed in author names).
(0000096)
graham (administrator)
2010-06-20 11:26

Fixed. The cryptic failure now doesn't happen, and such an extension is marked as having been installed incorrectly on the documentation page.

- Issue History
Date Modified Username Field Change
2010-06-18 09:30 EmacsUser New Issue
2010-06-18 10:41 jmcgrew Effect (cosmetic) Error message is badly worded => (mild) Compiler accepts invalid code
2010-06-18 10:41 jmcgrew Note Added: 0000040
2010-06-18 10:41 jmcgrew Severity serious => mild
2010-06-18 10:41 jmcgrew Status new => acknowledged
2010-06-19 13:04 jmcgrew Status acknowledged => confirmed
2010-06-20 11:26 graham Note Added: 0000096
2010-06-20 11:26 graham Status confirmed => resolved
2010-06-20 11:26 graham Resolution open => fixed
2010-06-20 11:26 graham Assigned To => graham
2010-06-30 18:07 jmcgrew Fixed in Version => 6E72
2010-07-01 23:07 jmcgrew Status resolved => closed
2010-08-06 18:23 EmacsUser Relationship added related to 0000238


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker