Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000626Core InformExtensionspublic2011-03-25 21:342014-05-07 07:34
ReporterRon Newcomb 
Assigned Tograham 
PrioritynormalSeveritycosmeticReproducibilityN/A
StatusclosedResolutionfixed 
PlatformPPCOSMac OS XOS Version10.4
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000626: questionable syntax in Lists.i6t and Combinations.i6t
DescriptionOut of all of Inform 7's underpinnings, these two template files use constructions like:

   for (i=0; i<no_items; i++)

which has semicolons instead of colons like Inform 6's for-loops are supposed to. I've found 15 instances of this, 12 of which are that exact line, and all are confined to just those two template files.

Tagswrongeffect
Effect(cosmetic) Error message is badly worded
Attached Files

- Relationships

-  Notes
(0001108)
Ron Newcomb (reporter)
2011-03-25 21:36

Er, actually I found a few more outside those two files. Just compile any auto.inf and browse through the warnings.

I only bring up this niggling little point because the source code is intended to be published as a literate program a la Knuth.
(0001110)
jmcgrew (administrator)
2011-03-27 14:06

Not sure how to categorize this, but it's definitely related to I7, not I6.
(0001115)
EmacsUser (manager)
2011-03-28 10:18

Confirmed. Jesse, do we also want an accepts-invalid bug filed against the I6 compiler?
(0001128)
EmacsUser (manager)
2011-04-09 16:15

The I6 compiler is giving a (suppressed) warning and changing the semicolons to colons. Because it intentionally accepts the invalid code, there is no I6 compiler bug.
(0001129)
jmcgrew (administrator)
2011-04-09 16:17

I'm tempted to write a feature request for I6 to stop giving the warning, but I don't know where those belong.
(0001358)
graham (administrator)
2011-10-15 01:03

The spectacle of somebody forgetting the syntax of his own language is probably not an edifying one, but there we are. I've fixed these.

- Issue History
Date Modified Username Field Change
2011-03-25 21:34 Ron Newcomb New Issue
2011-03-25 21:36 Ron Newcomb Note Added: 0001108
2011-03-27 14:04 jmcgrew Project Inform 6 => Core Inform
2011-03-27 14:06 jmcgrew Effect => (cosmetic) Error message is badly worded
2011-03-27 14:06 jmcgrew Note Added: 0001110
2011-03-27 14:06 jmcgrew Priority low => normal
2011-03-27 14:06 jmcgrew Status new => acknowledged
2011-03-27 14:06 jmcgrew Category General => Extensions
2011-03-27 14:06 jmcgrew Product Version 6.32 =>
2011-03-27 14:06 jmcgrew Tag Attached: wrongeffect
2011-03-27 14:06 jmcgrew Product Version => 6G60
2011-03-28 10:18 EmacsUser Note Added: 0001115
2011-03-28 10:18 EmacsUser Status acknowledged => confirmed
2011-04-09 16:15 EmacsUser Note Added: 0001128
2011-04-09 16:17 jmcgrew Note Added: 0001129
2011-09-20 22:15 EmacsUser Reproducibility have not tried => N/A
2011-10-15 01:03 graham Note Added: 0001358
2011-10-15 01:03 graham Status confirmed => resolved
2011-10-15 01:03 graham Resolution open => fixed
2011-10-15 01:03 graham Assigned To => graham
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:34 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker