Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000621Core InformPhrases and functional programmingpublic2011-03-21 12:222014-05-07 07:34
ReporterEmacsUser 
Assigned Tograham 
PrioritynormalSeverityseriousReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.5
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000621: Let phrase does not infer the kind of a rule
DescriptionThe attached source provokes

- - - -
Problem. You wrote 'let bar be the foo rule' : but this isn't a definite kind, and is instead a general description which might apply to many different kinds, so I can't see how to create this named value. (For example, 'let R be a relation' is vague because it doesn't make clear what R will relate - 'let R be a relation of numbers' would be fine.)
I was trying to match one of these phrases:

1. let (bar - a new name) be (foo rule - description of relations of values to values)
2. let (bar - a new name) be (foo rule - name of kind)
3. let (bar - a new name) be (foo rule - value)
4. let (bar - a temporary named value) be (foo rule - value)
This was what I found out:

bar = something unrecognised
foo rule = a values based rule producing values
- - - -

whereas this compiles fine:

- - - -
There is a room.
This is the foo rule:
    let bar be a rule;
    let bar be the foo rule.
- - - -
Minimal Source Text To Reproduce
There is a room.
This is the foo rule:
	let bar be the foo rule.
TagsNo tags attached.
Effect(serious) Compiler rejects valid code
Attached Files

- Relationships

-  Notes
(0002308)
graham (administrator)
2014-01-18 11:18

The problem was really that the kind of a constant rule was imprecisely calculated; "let" was correctly rejecting it. I've fixed this.

- Issue History
Date Modified Username Field Change
2011-03-21 12:22 EmacsUser New Issue
2011-03-21 13:35 jmcgrew Status new => acknowledged
2011-05-30 22:08 jmcgrew Status acknowledged => confirmed
2014-01-18 11:18 graham Note Added: 0002308
2014-01-18 11:18 graham Status confirmed => resolved
2014-01-18 11:18 graham Resolution open => fixed
2014-01-18 11:18 graham Assigned To => graham
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:34 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker