Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000620Core InformActivitiespublic2011-03-21 10:232014-05-07 07:34
ReporterRon Newcomb 
Assigned Tograham 
PrioritynormalSeverityseriousReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSWindowsOS VersionXP
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000620: 'while activity' clause used with 'when' clause either doesn't compile or doesn't work
DescriptionIn the source below, the last line doesn't ever print. It will print if I remove the 'when' clause. It will also print if I change "while listing nondescript items" to "while looking", suggesting it's something to do with checking activities, not actions.

Rearranging the while-when clauses to both use whiles or both use whens, with an 'and' or just the when/while instead of a conjunction, will not compile, giving an "I didn't understand your when/while clause" error.
 
Minimal Source Text To Reproduce
"foo"

Test is a room.

A thing has a number called the count. The indefinite article of a thing is usually "[a quantity 
of the item described]".

To say a quantity of (item - a thing): carry out the printing a quantity activity with item.
   
Printing a quantity of something is an activity on objects.

Last for printing a quantity:  say "[count of the parameter-object in words]"

Some balloons are a thing in Test. The count of balloons is 5.

For printing a quantity of balloons while listing nondescript items when 2 is 2:
   say "lots and lots".
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships

-  Notes
(0001100)
EmacsUser (manager)
2011-03-21 13:48

Hmm, confirmed the misbehavior, though I'm not sure yet how many bugs are here. In the attached source, TestActivity seems to be comparing the truth state ``whether or not the actor is the player and 2 is 2'' to the room Test. The comparison fails, of course, blocking the for rule. Also, ni will accept a room in place of the condition:

For printing a quantity of balloons while listing nondescript items when Test (this is the X rule):
    say "lots and lots of".
(0001104)
EmacsUser (manager)
2011-03-21 14:37

See the clone issues 0000622 and 0000623 for the other problems.
(0002313)
graham (administrator)
2014-01-18 12:18

The syntax analyser used to be rather lax here; it's now stricter, and won't let this test case happen.

- Issue History
Date Modified Username Field Change
2011-03-21 10:23 Ron Newcomb New Issue
2011-03-21 13:48 EmacsUser Effect (serious) Compiler rejects valid code => (serious/mild) Game compiles but misbehaves
2011-03-21 13:48 EmacsUser Note Added: 0001100
2011-03-21 13:48 EmacsUser Status new => confirmed
2011-03-21 14:23 EmacsUser Issue cloned 0000622
2011-03-21 14:35 EmacsUser Issue cloned 0000623
2011-03-21 14:37 EmacsUser Note Added: 0001104
2014-01-18 12:18 graham Note Added: 0002313
2014-01-18 12:18 graham Status confirmed => resolved
2014-01-18 12:18 graham Resolution open => fixed
2014-01-18 12:18 graham Assigned To => graham
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:34 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker