Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000619Core InformActivitiespublic2011-03-21 10:162014-05-07 07:34
ReporterRon Newcomb 
Assigned Tograham 
Platformx86OSWindowsOS VersionXP
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000619: code 10 on while/when conditions
DescriptionThe below source causes a code 10 in the Inform compiler. The error doesn't happen if I comment out either the last line, or, the next-to-last line, but both of them together causes the error.
Minimal Source Text To Reproduce
Test is a room.
Printing a quantity is an activity.
For printing a quantity while listing nondescript items:
	do nothing.
For printing a quantity while listing nondescript items while looking:
	do nothing.
TagsNo tags attached.
Effect(critical) Compiler crashes
Attached Files

- Relationships
has duplicate 0000934closed Critical Error 10 on complex activity rule only when another rule is in the rulebook 

-  Notes
EmacsUser (manager)
2011-03-21 12:58

Reduced and confirmed; looks like an edge case in comparing rule specificity:

Program received signal EXC_BAD_ACCESS, Could not access memory.
Reason: KERN_PROTECTION_FAILURE at address: 0x00000008
0x0000a587 in Semantics__Nouns__ExcerptMeanings__data ()
(gdb) bt
#0 0x0000a587 in Semantics__Nouns__ExcerptMeanings__data ()
#1 0x000d3359 in Code__Activities__Lists__parse ()
#2 0x000d8dd3 in Code__Phrases__Context__compare_specificity ()
#3 0x000d8ef0 in compare_specificity_of_br ()
#4 0x000d90f6 in Code__Rules__list_judge_ordering ()
#5 0x00118c75 in Code__Rulebooks__compile_rule_phrases ()
#6 0x00118f0d in Code__Phrases__compile_first_block ()
#7 0x0012f724 in Config__Template__interpret ()
#8 0x0012a966 in Config__Template__interpret ()
#9 0x001314bc in main ()
graham (administrator)
2011-10-07 14:28

Inform's syntax analyser has been rewritten since this bug was filed; I can't reproduce the bug now, and looking at the code in the backtrace, I can't see anything which would cause it. So it's probably fair to say this is fixed.

- Issue History
Date Modified Username Field Change
2011-03-21 10:16 Ron Newcomb New Issue
2011-03-21 12:58 EmacsUser Note Added: 0001099
2011-03-21 12:58 EmacsUser Severity serious => critical
2011-03-21 12:58 EmacsUser Status new => confirmed
2011-03-21 12:58 EmacsUser Steps to Reproduce Updated View Revisions
2011-10-07 14:28 graham Note Added: 0001328
2011-10-07 14:28 graham Status confirmed => resolved
2011-10-07 14:28 graham Resolution open => fixed
2011-10-07 14:28 graham Assigned To => graham
2012-06-16 15:13 EmacsUser Relationship added has duplicate 0000934
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:34 jmcgrew Status resolved => closed

Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker