Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000615Core InformReleasing, bibliographic data, cBlorbpublic2011-03-15 14:182014-05-07 07:34
ReporterRon Newcomb 
Assigned Tograham 
Platformx86OSWindowsOS VersionXP
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000615: Story title ending in question mark cannot be Released
DescriptionWindows, not Mac. Clicking RELEASE or RELEASE FOR TESTING on the source below doesn't produce any zblorb or gblorb file. Not sure if question marks are OK in a title or not, but the Mac has no problem.

Are the filename allowances different between platforms?
Minimal Source Text To Reproduce
"test?" by Ron Newcomb. There is room.
Effect(serious) Compiler rejects valid code
Attached Files

- Relationships

-  Notes
DavidK (developer)
2011-03-15 15:07

A question mark is not valid in a Windows file name, as the question mark is the single-character wildcard. NI should really flag this as an error, or drop the question mark from the final output file name.
EmacsUser (manager)
2011-03-15 16:43

For now I'm classifying this one as a bug in the release process.
Victor Gijsbers (reporter)
2011-03-20 18:12

Does NI know which filesystem it is running on? Because a question-mark is certainly legal in many other filesystems, such as the default OSX and Linux filesystems. It would seem undesirable for NI to restrict the filename of the released file using restrictions that do not actually exist on the filesystem it is running on.

(As a reductio ad absurdum, consider the view that NI should restrict your game title to MS-DOS-legal file names. Nobody wants that, because nobody is using it. But why would I want to be restricted by NTSF if I'm using EXT4?)
graham (administrator)
2011-10-21 12:12

Inform does know what platform it's on, but I think I'd like the behaviour here to be consistent across platforms. I've suppressed both ? and * in story file filenames.

- Issue History
Date Modified Username Field Change
2011-03-15 14:18 Ron Newcomb New Issue
2011-03-15 15:07 DavidK Note Added: 0001090
2011-03-15 16:43 EmacsUser Note Added: 0001094
2011-03-15 16:43 EmacsUser Severity mild => serious
2011-03-15 16:43 EmacsUser Status new => confirmed
2011-03-15 16:43 EmacsUser Category Source text and punctuation => Releasing, bibliographic data, cBlorb
2011-03-15 16:43 EmacsUser Tag Attached: wrongeffect
2011-03-20 18:12 Victor Gijsbers Note Added: 0001097
2011-10-21 12:12 graham Note Added: 0001419
2011-10-21 12:12 graham Status confirmed => resolved
2011-10-21 12:12 graham Resolution open => fixed
2011-10-21 12:12 graham Assigned To => graham
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:34 jmcgrew Status resolved => closed

Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker