Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000604Core InformModel worldpublic2011-03-06 23:202014-05-07 07:33
ReporterAaronReed 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.6
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000604: Going within a vehicle driven by an NPC does not update the location
DescriptionIn the source text below, where the player is in a vehicle being "driven" by an NPC, the report going rule sometimes writes the message as if the player is observing it from the room being arrived in-- eg for going south, "Bob arrives from the north in the truck, taking you along." Some directions, however, produce more natural-sounding text narrating the travel from before the movement: "Bob goes north in the truck, taking you along."

The cause, it seems, is that the location is not being updated from the Southwest Corner to the Northwest Corner.
Minimal Source Text To Reproduce
Southwest Corner is a room. Northwest Corner is north of southwest corner.

The truck is a vehicle in Southwest Corner. Bob is a man in truck. The player is in truck.

Every turn:
	showme the location;
	if location of Bob is Southwest Corner:
		try Bob going north;
	otherwise if location of Bob is Northwest Corner:
		try Bob going south.
		
test me with "wait / wait"
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships

-  Notes
(0001075)
EmacsUser (manager)
2011-03-07 17:03

While the NPC's going action is moving the PC object, it isn't changing the variable ``the location.'' Hence the strange messages from the report rules. It looks like backdrop position updates and the reckoning of darkness also aren't occurring.

I have updated the description and moved this report to the model world category (because it involves the going action in particular, and is not the fault of the action-processing machinery).
(0001753)
climbingstars (reporter)
2012-08-05 05:30
edited on: 2012-08-10 16:20

The problem also occurs when the player is in a container or on a supporter that is pushable between rooms, with an NPC pushing the aforementioned item into another room. Attempting to simulate the output for (12.13. Report rules for actions by other people) in the documentation with the cage and the automobile gives this problem.

"Test"

A persuasion rule: persuasion succeeds.

Every turn (this is the display location variables rule):
say "[The location] -> The location.[line break][The location of the player] -> The location of the player.".

First Room is west of Second Room. Second Room is north of Third Room. Third Room is east of Fourth Room. Fourth Room is south of First Room.

Clark Gable is a person in the first room. The cage is in the first room. The cage is an enterable, pushable between rooms container. The automobile is in the first room. The automobile is a transparent vehicle.

Test me with "get in cage / clark, get in automobile / clark, push cage east / clark, push cage south / clark, push cage west / clark, push cage north".

(0001754)
climbingstars (reporter)
2012-08-05 06:10

This provides a temporary fix for the problem.

Carry out an actor going (this is the update player movement rule):
if the location is not the location of the player begin;
now the location is the location of the player;
surreptitiously reckon darkness;
update backdrop positions;
end if.
(0002485)
graham (administrator)
2014-02-13 11:42

Fixed. I've incorporated the correction to location into the "move player and vehicle rule", to preserve the invariant, but rewritten the "move floating objects rule" and "check light in new location rule" to do these things when the player moves through other peoples' vehicular travel, too.

- Issue History
Date Modified Username Field Change
2011-03-06 23:20 AaronReed New Issue
2011-03-07 10:02 jmcgrew Status new => acknowledged
2011-03-07 17:03 EmacsUser Note Added: 0001075
2011-03-07 17:03 EmacsUser Status acknowledged => confirmed
2011-03-07 17:03 EmacsUser Category Actions => Model world
2011-03-07 17:03 EmacsUser Summary Report going within a vehicle driven by an NPC is sometimes incorrect => Going within a vehicle driven by an NPC does not update the location
2011-03-07 17:03 EmacsUser Description Updated View Revisions
2011-03-07 17:03 EmacsUser Steps to Reproduce Updated View Revisions
2012-08-05 05:30 climbingstars Note Added: 0001753
2012-08-05 06:10 climbingstars Note Added: 0001754
2012-08-10 16:20 climbingstars Note Edited: 0001753 View Revisions
2014-02-13 11:42 graham Note Added: 0002485
2014-02-13 11:43 graham Status confirmed => resolved
2014-02-13 11:43 graham Resolution open => fixed
2014-02-13 11:43 graham Assigned To => graham
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker