Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000600Gnome Inform application[IDEs] Installation and Platform Issuespublic2011-03-05 12:072014-05-07 07:40
Reporterelvenic 
Assigned Topchimento 
PrioritynormalSeveritymildReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformLinux/GNOMEOSMint Linux 10 Debian EditionOS VersionAny
Product Version 
Target VersionFixed in Version6L02 
Summary0000600: GConf schemas mysteriously not installed
DescriptionThis is my first attempt to run Inform7 on linux. I'm using Mint Linux 10 Debian Edition, that should be straightforward Debian Testing with some Mint additions, but I think they are irrelevant, because apt basically points to the Debian Testing repositories.

I've compiled and installed into /usr/local Gnome Inform from tarball I7_6G60_GNOME_Source.tar.gz. After I installed required dev packages, compile was OK and did not report any errors (some warnings were reported though). Now I have /usr/local/bin/gnome-inform binary. When I try to run it, it outputs some GTK, GLib and GConf critical messages and then segfaults.

When I run it under gdb and print backtrace after the segfault, I see following:

--- cut here 8< ----------------------------------
$ cd /usr/local/bin
$ gdb ./gnome-inform7
GNU gdb (GDB) 7.2-debian
[... skip copiright ...]
Reading symbols from /usr/local/bin/gnome-inform7...done.
(gdb) run
Starting program: /usr/local/bin/gnome-inform7
[Thread debugging using libthread_db enabled]

(gnome-inform7:9871): GtkSourceView-CRITICAL **: gtk_source_style_scheme_manager_get_scheme: assertion `scheme_id != NULL' failed

(gnome-inform7:9871): GConf-CRITICAL **: gconf_engine_set: assertion `value != NULL' failed

(gnome-inform7:9871): GConf-CRITICAL **: gconf_value_get_string: assertion `value != NULL' failed

(gnome-inform7:9871): Gtk-CRITICAL **: IA__gtk_font_button_set_font_name: assertion `fontname != NULL' failed

(gnome-inform7:9871): GLib-CRITICAL **: g_ascii_strcasecmp: assertion `s2 != NULL' failed

(gnome-inform7:9871): GConf-CRITICAL **: gconf_engine_set: assertion `value != NULL' failed

(gnome-inform7:9871): GConf-CRITICAL **: gconf_value_get_string: assertion `value != NULL' failed

Program received signal SIGSEGV, Segmentation fault.
0xb6560e3a in strcmp () from /lib/i686/cmov/libc.so.6
(gdb) bt
#0 0xb6560e3a in strcmp () from /lib/i686/cmov/libc.so.6
#1 0x0808e4d5 in select_style_scheme (view=0x8196070, id=0x0) at prefs.c:544
#2 0x0807e4f5 in on_config_style_scheme_changed (client=0x81a1170, id=2466250756, entry=0x8159260, list=0x8196070) at configfile.c:206
#3 0xb7fb88fc in ?? () from /usr/lib/libgconf-2.so.4
#4 0xb7fa8a50 in gconf_listeners_notify () from /usr/lib/libgconf-2.so.4
#5 0xb7fb6734 in ?? () from /usr/lib/libgconf-2.so.4
#6 0xb7fb881f in gconf_client_notify () from /usr/lib/libgconf-2.so.4
#7 0x0807df1d in trigger_config_file () at configfile.c:394
#8 0x0809f379 in main (argc=1, argv=0xbfffee04) at main.c:74
(gdb)

--- cut here 8< ----------------------------------

The GtkSourceView Critical messages says that the scheme_id is NULL, and the backtrace says that segfault occured in strcmp() within 'select_style_scheme()', it looks to me that the problem is with some scheme or syle scheme. May be I lack some style definition on my machine?
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0001077)
pchimento (developer)
2011-03-09 23:00

It looks like GConf isn't working properly, since the style scheme isn't the only thing that's going wrong. Can you try installing the "gconf-editor" package? That will add a program called something like "Configuration Editor" to your applications menu. Run that, and take a look at the keys in /apps/gnome-inform7/EditorSettings. Can you post them here please?
(0001078)
elvenic (reporter)
2011-03-09 23:08

I don't see /apps/gnome-inform7 key in the gconf-editor at all.
(0001079)
pchimento (developer)
2011-03-10 12:57

Ok, then apparently the file gnome-inform7.schemas never got installed properly. Try running make uninstall and then make install again.
(0001080)
elvenic (reporter)
2011-03-13 10:52

Yes, running 'sudo make uninstall' and then 'sudo make install' installed schemas into /usr/local/etc/gconf/schemas/gnome-inform7 (I checked that this file now is present), and gconf-editor now sees /apps/gnome-inform7 set of keys. After this, the gnome-inform7 started successfully, without any crash.

I have no idea though why on the first install attempt gconf schemas were not installed.

Anyway, now I can run gnome-inform7 and play with it :)
(0001081)
pchimento (developer)
2011-03-13 12:47

Ok, closing for now unless someone else turns up with the same problem of the schemas not getting installed.
(0001154)
pchimento (developer)
2011-04-28 13:14

Someone else did - me, to be precise, when installing on a freshly installed Fedora 15 beta. Not even make uninstall and make install fixed the problem. Reopening and will investigate at a later date. Running the command

sudo GCONF_CONFIG_SOURCE=xml:merged:/etc/gconf/gconf.xml.defaults/ gconftool-2 --makefile-install-rule gnome-inform7.schemas

installed the keys properly. This is a workaround for the time being, if anyone else has this problem.
(0001467)
pchimento (developer)
2011-11-27 06:03

This is still a mystery. I've found out that the schemas are visible to root, but not to any normal users, as described in this e-mail to the GTK mailing list that nobody ever answered:

http://mail.gnome.org/archives/gtk-list/2010-July/msg00085.html [^]
(0001468)
pchimento (developer)
2011-11-27 09:21

My previous workaround didn't work anymore when I tried installing on a freshly-installed Fedora 16. This time, rebooting after installing seems to work.
(0001512)
pchimento (developer)
2012-01-08 13:50

I've filed a bug with GConf:

https://bugzilla.gnome.org/show_bug.cgi?id=664921 [^]

I doubt it will be fixed, however, as GConf is deprecated. As soon as Debian Stable catches up with modern technology, I will remove GConf from Inform. Most of the work has already been done, thanks to Matteo Settenvini. It lives in the "gsettings" branch of the Git repository.
(0001952)
pchimento (developer)
2013-01-05 14:19

I have more information; this is a bug with GConf and will not be fixed, but there is an easy workaround, so I have implemented that.

- Issue History
Date Modified Username Field Change
2011-03-05 12:07 elvenic New Issue
2011-03-09 23:00 pchimento Note Added: 0001077
2011-03-09 23:08 elvenic Note Added: 0001078
2011-03-10 12:57 pchimento Note Added: 0001079
2011-03-13 10:52 elvenic Note Added: 0001080
2011-03-13 12:47 pchimento Note Added: 0001081
2011-03-13 12:48 pchimento Assigned To => pchimento
2011-03-13 12:48 pchimento Status new => assigned
2011-03-13 12:48 pchimento Status assigned => resolved
2011-03-13 12:48 pchimento Resolution open => unable to reproduce
2011-04-28 13:14 pchimento Note Added: 0001154
2011-04-28 13:14 pchimento Status resolved => confirmed
2011-04-28 13:15 pchimento Severity critical => serious
2011-04-28 13:15 pchimento Reproducibility always => sometimes
2011-04-28 13:15 pchimento Resolution unable to reproduce => reopened
2011-04-28 13:15 pchimento Platform Mint Linux 10 Debian Edition => Linux/GNOME
2011-04-28 13:17 pchimento Summary Gnome-Inform segfaults on startup => GConf schemas mysteriously not installed
2011-08-04 12:02 pchimento Severity serious => mild
2011-11-27 06:03 pchimento Note Added: 0001467
2011-11-27 09:21 pchimento Note Added: 0001468
2012-01-08 13:50 pchimento Note Added: 0001512
2012-01-08 13:51 pchimento Status confirmed => closed
2012-01-08 13:51 pchimento Resolution reopened => won't fix
2013-01-05 14:19 pchimento Note Added: 0001952
2013-01-05 14:21 pchimento Status closed => resolved
2013-01-05 14:21 pchimento Resolution won't fix => fixed
2014-05-07 07:40 jmcgrew Fixed in Version => 6L02
2014-05-07 07:40 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker