Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000060Mac OS X Inform application[IDEs] User Interfacepublic2010-06-18 05:412010-07-01 23:59
ReporterJuhana 
Assigned Toahunter 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.6
Product Version6E59 
Target VersionFixed in Version6E72 
Summary0000060: Search doesn't consider non-alphabet characters as word boundaries
DescriptionWhen you search the manual for FOO it searches exact matches and words starting with FOO (FOOBAR matches but BARFOO doesn't.) The search should consider every non-alphabet character as a word boundary, because at the moment FOO doesn't match any of the following:

Understand "FOO" as...
The bar (FOO in other words)...
Understand "take [FOO]" as...

The last one is especially critical, because if you search for tokens or substitutions like "things preferably held" (without quotes) it doesn't find anything; searching for "[things preferably held]" finds three matches.
TagsNo tags attached.
Attached Files

- Relationships
has duplicate 0000113closedjmcgrew Search fails to find words next to double quotes 

-  Notes
(0000050)
EmacsUser (manager)
2010-06-18 17:35

Confirmed. The inspector identifies neither the left nor the right of characters like `[' to be a word boundary.
(0000089)
ahunter (developer)
2010-06-20 09:46

Should be fixed in UI build 2751.

http://files.me.com/logicalshift/0wzktq [^]

- Issue History
Date Modified Username Field Change
2010-06-18 05:41 Juhana New Issue
2010-06-18 08:50 jmcgrew Status new => acknowledged
2010-06-18 17:35 EmacsUser Note Added: 0000050
2010-06-18 17:35 EmacsUser Status acknowledged => confirmed
2010-06-20 07:29 graham Assigned To => ahunter
2010-06-20 07:29 graham Status confirmed => assigned
2010-06-20 09:46 ahunter Note Added: 0000089
2010-06-20 09:46 ahunter Status assigned => resolved
2010-06-20 09:46 ahunter Resolution open => fixed
2010-06-23 20:42 jmcgrew Relationship added has duplicate 0000113
2010-07-01 23:08 jmcgrew Fixed in Version => 6E72
2010-07-01 23:08 jmcgrew Status resolved => closed
2010-07-01 23:20 jmcgrew Fixed in Version => 6E72
2010-07-01 23:59 jmcgrew Product Version => 6E59


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker