Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000589Core InformAssertions and creationspublic2011-02-28 01:162014-05-07 07:34
ReporterFuchsia tude 
Assigned Tograham 
Platformx86OSWindowsOS Version7
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000589: Defining a room in the same direction from a door as its first side causes weird error message
DescriptionThis is the report produced by Inform 7 (build 6G60) on its most recent run through:

Problem. Treasure room, a room, seems to have a map connection which goes through doorway, a door: but that doesn't seem physically possible, since the rooms on each side of doorway have been established as Passageway and .

 See the manual: 3.12 > Doors
Minimal Source Text To Reproduce
A doorway is a door. It is west from the Treasure room.
The Passageway is east from the doorway.
TagsNo tags attached.
Effect(cosmetic) Error message is badly worded
Attached Files

- Relationships

-  Notes
graham (administrator)
2011-10-15 09:10

Fixed; there's a new problem message to catch just this case.

- Issue History
Date Modified Username Field Change
2011-02-28 01:16 Fuchsia tude New Issue
2011-02-28 11:57 jmcgrew Status new => acknowledged
2011-02-28 16:13 EmacsUser Status acknowledged => confirmed
2011-10-15 09:10 graham Note Added: 0001378
2011-10-15 09:10 graham Status confirmed => resolved
2011-10-15 09:10 graham Resolution open => fixed
2011-10-15 09:10 graham Assigned To => graham
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:34 jmcgrew Status resolved => closed

Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker