Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000587Core InformKinds and type checkingpublic2011-02-25 21:032014-05-07 07:34
Reportervimes 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.6
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000587: Certain tables cause Basic Help Menu entries to be truncated
DescriptionTo reproduce, run the source, then >HELP, select Instructions for Play, select If You Get Stuck, select Read Carefully.

Notice that the text is cut off:

Check the whole screen. Are there extra windows besides the main window? What's going on in those? Check out the status bar, if there is one -- it may contain the name of the room you're in, your score, the time of day, your character's state of health, or some other important information. If there's something up there, it's worth paying attention to that, too. When and where does it change? Wh

(text ends with "Wh")

as opposed to the expected:

Check the whole screen. Are there extra windows besides the main window? What's going on in those? Check out the status bar, if there is one -- it may contain the name of the room you're in, your score, the time of day, your character's state of health, or some other important information. If there's something up there, it's worth paying attention to that, too. When and where does it change? Why is it significant? If the bar is describing your character's health, you can bet there is probably a point at which that will be important.

This was originally noted with Recorded Endings included as well; the table included below is the minimal code I could find to reproduce the cut-off bug.
Minimal Source Text To Reproduce
Include Basic Help Menu by Emily Short.

[The Table of Stuff  is a minimal test case extracted from Recorded Endings.
Include Recorded Endings by Emily Short.  The File of Conclusions is called "mwconclusions".

]

Table of Stuff
description (indexed text)
indexed text
with 1 blank rows.	 

This is a room.  
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships
related to 0000593closedgraham RawBufferSize is not reset in INDEXED_TEXT_TY_Cast; out-of-bounds memory access is possible converting text to indexed text 

-  Notes
(0001063)
EmacsUser (manager)
2011-03-01 18:46
edited on: 2011-03-01 18:49

The bug is in the I6 routine INDEXED_TEXT_TY_Cast, not the extension; a reduced test case:

- - - -
There is a room.
To decide what text is the long string:
    decide on "xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx xxxxxxx abcdefg".
When play begins:
    let the conversion be indexed text;
    now the conversion is the long string;
    showme the conversion.
- - - -

The cause is the missing line

- - - -
buffx = (RawBufferSize + 2)*WORDSIZE;
- - - -

just before

- - - -
jump RetryWithLargerBuffer;
- - - -

Edit: changed long string to wrap better on Mantis; corrected a typo.

(0001073)
vimes (reporter)
2011-03-07 07:13

Ah, of course it's not in the extension proper. Must have been asleep when I wrote the report.

(Should it be moved? Closed and re-opened?)
(0001093)
EmacsUser (manager)
2011-03-15 16:21

Moved now, and confirmed.
(0001499)
graham (administrator)
2011-12-17 17:01

Fixed. (The supplied fix was indeed right.)

- Issue History
Date Modified Username Field Change
2011-02-25 21:03 vimes New Issue
2011-03-01 18:46 EmacsUser Note Added: 0001063
2011-03-01 18:48 EmacsUser Note Edited: 0001063 View Revisions
2011-03-01 18:49 EmacsUser Note Edited: 0001063 View Revisions
2011-03-01 19:00 EmacsUser Relationship added related to 0000593
2011-03-07 07:13 vimes Note Added: 0001073
2011-03-15 16:13 jmcgrew Project Built-In Extensions => Core Inform
2011-03-15 16:14 jmcgrew Effect => (serious/mild) Game compiles but misbehaves
2011-03-15 16:14 jmcgrew Status new => acknowledged
2011-03-15 16:14 jmcgrew Category Basic Help Menu (Emily Short) => Kinds and type checking
2011-03-15 16:21 EmacsUser Note Added: 0001093
2011-03-15 16:21 EmacsUser Status acknowledged => confirmed
2011-12-17 17:01 graham Note Added: 0001499
2011-12-17 17:01 graham Status confirmed => resolved
2011-12-17 17:01 graham Resolution open => fixed
2011-12-17 17:01 graham Assigned To => graham
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:34 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker