Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000585Core InformRules and rulebookspublic2011-02-25 07:162014-05-07 07:33
Assigned Tograham 
Platformx86OSWindowsOS Version7
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000585: After rule for asking someone to try doing something does not get triggered after successful asking action
DescriptionIt appears that the action processing rules are not checking for the presence of any "after" rules in the case where a non-player actor has been asked to do something. The submitted example code shows three such rules with varying degrees of specificity; none of them are triggered, even though with rules and actions tracing on, the asking action is shown to have succeeded.
Minimal Source Text To Reproduce
"Test Story" by "Otis T. Dog"

Noplace is a room.

Bob is a person in Noplace.

Persuasion rule for asking Bob to try doing something: rule succeeds.

After asking someone to try doing something, say "After: Someone did it!"

After asking Bob to try doing something, say "After: Bob did it!"

After asking Bob to try waiting, say "Bob actually waited!"

test me with "bob, wait / rules / actions / bob, wait"
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships
has duplicate 0000586closed Carry out rule for asking someone to try doing something is (appropriately?) ignored 

-  Notes
EmacsUser (manager)
2011-02-27 20:08

Confirmed; it looks like the actor is set to Bob when the after rules get their chance to fire, but the I6 guard requires the actor to be the player for the rule to apply.
EmacsUser (manager)
2011-02-27 20:54

Carry out rules are also affected; see 0000586.
graham (administrator)
2014-03-13 11:46

Really a design change rather than a bug fix, but it has no negative implications that I can think of, so I've made it.

- Issue History
Date Modified Username Field Change
2011-02-25 07:16 otistdog New Issue
2011-02-27 20:08 EmacsUser Note Added: 0001058
2011-02-27 20:08 EmacsUser Status new => confirmed
2011-02-27 20:53 EmacsUser Relationship added has duplicate 0000586
2011-02-27 20:54 EmacsUser Note Added: 0001061
2014-03-13 11:46 graham Note Added: 0002551
2014-03-13 11:46 graham Status confirmed => resolved
2014-03-13 11:46 graham Resolution open => fixed
2014-03-13 11:46 graham Assigned To => graham
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed

Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker