Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000058Core InformSource text and punctuationpublic2010-06-17 21:572010-10-24 11:58
ReporterJim Aikin 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSWindowsOS Version7
Product Version6E59 
Target VersionFixed in Version6E72 
Summary0000058: Leading/trailing apostrophes can't be used in story title
DescriptionIf an apostrophe occurs at the beginning or end of a word in the story title, it's replaced with a double quote, with no obvious way to override that behavior.
Minimal Source Text To Reproduce
"Gamin' the System"

Home is a room.
Additional InformationThe code above results in:

  Gamin" the System
  An Interactive Fiction

Replacing the title with "Gamin['] the System" causes a compile-time error instead (which is incorrectly repeated):

  This is the report produced by Inform 7 (build 6E59) on its most recent run through:

  Problem. You wrote '"Gamin['] the System"' : but text substitutions can't be used in bibliographic data, such as the title or author of a work of IF.

  Problem. You wrote '"Gamin['] the System"' : again, text substitutions can't be used in bibliographic data.

A workaround is to replace the I6 template section where the story title is defined.
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships
related to 0000553closedgraham Apostrophe in story headline 

-  Notes
(0000032)
emshort (administrator)
2010-06-17 22:48

This was basically closed as "will not fix" in the previous build. Here is the bug report and response from last time:

===

"Rattlin['] Bog" by Sean Huxter
- - - - - - -
Problem. An internal error has occurred: Too late for further text substitutions. The current sentence is '"Rattlin['] Bog - based on the traditional Irish folk song" by Sean Huxter and Sean Dickinson' ; the error was detected at line 286 of "Chapter 10/String Constants.w". This should never happen, and I am now halting in abject failure.

Sorry about this. You still aren't allowed to do it (for reasons
which are a bit messy but to do with bibliographic data needing
to be exported to various other formats), but there's a much
more polite problem message now.
(0000033)
jmcgrew (administrator)
2010-06-17 22:58

I can see why text substitutions in general wouldn't be allowed there, but apostrophes are already allowed in the title when they occur in the middle of a word.

It seems like I7 is treating the title as a regular text string and then disqualifying it if it contains substitutions -- the generated code has a text routine for the title -- but maybe it should be special cased instead.
(0000034)
emshort (administrator)
2010-06-17 23:02

For what it's worth, I agree it's desirable to (or, more precisely, pretty lame not to) have a way to do this, but I think it goes in suggestions rather than bug reports.
(0000035)
jmcgrew (administrator)
2010-06-17 23:23

You're right. Taking it to http://inform7.uservoice.com/forums/57320-general/suggestions/841221-bibliography-syntax-allow-in-the-story-title [^]
(0000036)
jmcgrew (administrator)
2010-06-17 23:47

The manual says this syntax is allowed (23.2, Bibliographic data):

<quote>
The text of these bibliographic descriptions cannot normally include text substitutions, since they are written into external descriptions of the story file as part of its "binding". One exception is allowed, though: "[']" makes a literal apostrophe, and can be used if we need to override Inform's normal conventions to do with converting apostrophes at the ends of words to double-quotes. For instance:

"Summer of [']69" by Buzz Aldrin
</quote>

So there must be a bug here, if not in the program then in the documentation.
(0000044)
mslattery (reporter)
2010-06-18 15:16

The "[']" syntax works in this context, as described in the manual, in build 5U92.
(0000094)
graham (administrator)
2010-06-20 10:54

Oh, very well, then. I have fixed this. Apostrophe substitution no longer applies to the story title; and ['] produces a simple ', in case anyone is still using it.

- Issue History
Date Modified Username Field Change
2010-06-17 21:57 jmcgrew New Issue
2010-06-17 21:57 jmcgrew Status new => acknowledged
2010-06-17 21:58 jmcgrew Status acknowledged => confirmed
2010-06-17 22:48 emshort Note Added: 0000032
2010-06-17 22:49 emshort Resolution open => won't fix
2010-06-17 22:58 jmcgrew Note Added: 0000033
2010-06-17 23:02 emshort Note Added: 0000034
2010-06-17 23:23 jmcgrew Note Added: 0000035
2010-06-17 23:23 jmcgrew Status confirmed => closed
2010-06-17 23:47 jmcgrew Assigned To => graham
2010-06-17 23:47 jmcgrew Note Added: 0000036
2010-06-17 23:47 jmcgrew Status closed => feedback
2010-06-17 23:47 jmcgrew Resolution won't fix => reopened
2010-06-18 15:16 mslattery Note Added: 0000044
2010-06-20 10:54 graham Note Added: 0000094
2010-06-20 10:54 graham Status feedback => resolved
2010-06-20 10:54 graham Resolution reopened => fixed
2010-06-30 18:07 jmcgrew Fixed in Version => 6E72
2010-07-01 23:07 jmcgrew Status resolved => closed
2010-10-24 11:58 jmcgrew Reporter jmcgrew => Jim Aikin
2011-02-12 18:58 jmcgrew Relationship added related to 0000553


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker