Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000577Core InformIndexingpublic2011-02-20 15:012014-09-15 17:34
Assigned Tograham 
Platformx86OSMac OS XOS Version10.6
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000577: Missing "Index" directory in .inform project causes ni compiler to error out

1. Create a new Inform 7 project ("Test", say). Enter any minimal code, save. Close the project.
2. Remove the directory Test.inform/Index
3. Open Test.inform
4. Attempt to compile.

Expected result: The directory "Index" and contents are recreated.

Actual result:

Error: Translating the Source - Failed

More details and progress output in addtl. info.


If Preferences : Advanced : Cleaning : "Clean Build Files" and "Also clean out index files" are both checked, opening, closing, and then re-opening the project will create a missing Index directory.

If not, any valid Index directory (in fact, only the "Headings.xml" file needs be present) can be copied into the project, and Inform will gracefully throw it away and create a new valid index.

Failed workarounds:

Simply creating the Index directory, or creating the Index directory and a blank Headings.xml, do not produce a workaround.

(My apologies if the category and/or effect are set sub-optimally.)
Minimal Source Text To Reproduce
This is a room.
Additional Information(...)

When a program like the I7 compiler fails, it typically returns an error number: this time, the number was 2, so I7 probably stopped because of a fatal file-system error.


Progress output:

Launching: ni "-rules" "/Applications/" "-package" "/Users/vimes/Source/if/Test.inform" "-extension=z8" "-log"
Inform 7 build 6G60 has started.
I've now read your source text, which is 9 words long.
++ 0% (Lexical analysis)
++ 5% (Semantic analysis)
I've also read Standard Rules by Graham Nelson, which is 39455 words long.
Can't open headings file
Offending filename: </Users/vimes/Source/if/Test.inform/Index/Headings.xml>

Compiler finished with code 2
TagsNo tags attached.
Effect(critical) Compiler crashes
Attached Files

- Relationships
related to 0000541closed Mac OS X Inform application Source will not compile if Index folder/files missing? 

-  Notes
graham (administrator)
2011-10-07 12:33

I think it's arguable that people who take deliberate steps to damage the interior of an Inform project bundle deserve what they get, but on balance, I agree: the preferred behaviour is just to repair the thing with the silent patience of a saint. Inform now does this.
curiousdannii (developer)
2014-09-15 17:34

A late comment Graham, but removing the Index and Build folders is a convention when using a source code control system like Git. Anything which is produced by the compiler and which changes frequently shouldn't be included in a git repository, or else you end up with a situation where 90% of your commit changes are metadata.

- Issue History
Date Modified Username Field Change
2011-02-20 15:01 vimes New Issue
2011-02-24 20:47 jmcgrew Effect (serious) Compiler rejects valid code => (critical) Compiler crashes
2011-02-24 20:47 jmcgrew Severity mild => critical
2011-02-24 20:47 jmcgrew Additional Information Updated View Revisions
2011-02-24 20:47 jmcgrew Status new => acknowledged
2011-02-27 19:28 EmacsUser Status acknowledged => confirmed
2011-03-01 15:49 EmacsUser Relationship added related to 0000541
2011-10-07 12:33 graham Note Added: 0001324
2011-10-07 12:33 graham Status confirmed => resolved
2011-10-07 12:33 graham Resolution open => fixed
2011-10-07 12:33 graham Assigned To => graham
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:34 jmcgrew Status resolved => closed
2014-09-15 17:34 curiousdannii Note Added: 0003183

Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker