Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000571Core InformTablespublic2011-02-19 12:482014-05-07 07:35
ReporterFuchsia tude 
Assigned Tograham 
Platformx86OSWindowsOS Version7
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000571: Naming a table with an alphanumeric number will not compile
DescriptionWWI 15.1 states "We can then either give a table number (this need not actually be a number: Table C2, or some such, would be fine), " but NI will not compile such a table.
Minimal Source Text To Reproduce
Table C2
a person

There is a room.
Additional InformationThis is the report produced by Inform 7 (build 6G60) on its most recent run through:

Problem. You wrote 'Table C2 believer a person' : but this does not start with a legal table name, since a table is required either to have a number, or to be a table 'of' something (or both). For example: 'Table 5', 'Table of Blue Meanies', and 'Table 2 - Submarine Hues' are all allowed, but 'Table concerning Pepperland' is not.
TagsNo tags attached.
Effect(serious) Compiler rejects valid code
Attached Files

- Relationships

-  Notes
graham (administrator)
2011-10-21 14:10


- Issue History
Date Modified Username Field Change
2011-02-19 12:48 Fuchsia tude New Issue
2011-02-24 20:34 jmcgrew Status new => confirmed
2011-02-24 20:34 jmcgrew Additional Information Updated View Revisions
2011-10-21 14:10 graham Note Added: 0001420
2011-10-21 14:10 graham Status confirmed => resolved
2011-10-21 14:10 graham Resolution open => fixed
2011-10-21 14:10 graham Assigned To => graham
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:35 jmcgrew Status resolved => closed

Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker