Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000558Documentation, Examples, and Web SiteExamplespublic2011-02-12 20:322014-05-07 07:38
Reporterotistdog 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version6L02 
Summary0000558: Example 193, "3 AM", illustrates the creation, but not the use of a custom past participle
DescriptionI noticed while reading WI 12.8 that, although the focus of the section seems to be the creation of custom past participles, the attached example illustrates the creation but not the use of a custom past participle.

The included source text is a functioning reworked example that does illustrate the use of a custom past participle. The time-based expiration of fizziness in the original example had to be dropped because trying to test for the number of turns past the shaking event causes a compiler crash (see issue 0000484). Feel free to use any or all of the reworked example in updated documentation, if it seems to be of use.
Minimal Source Text To Reproduce
"3:01 AM"

Understand "shake [something preferably held]" as shaking.

Shaking is an action with past participle shaken, applying to one carried thing.

Report shaking:
	say "Nothing results of your shaking [the noun]."

After shaking a closed container when something is in the noun:
	say "Something rattles inside [the noun]."

After shaking a closed transparent container when something is in the noun:
	say "Inside [the noun] there are banging noises produced by [the list of things contained by the 
noun]."

After shaking an open container which contains something:
	say "[The list of things contained by the noun] might fly out."

The Wawa is a room. "A convenience store, if you like to call it that, vending the usual assortment 
of chips, donuts, soda, and beer. There is something of a line at the sandwich counter."

The box of enrobed cakes is in the Wawa. "A box of Tastykake Enrobed Cakes has fallen off its shelf." 
The description is "'Enrobed Cakes' is a fancy term for 'strange sponge-like baked good, covered 
in a thin shell of waxy chocolate'. They are addictive, but not in a way that lets you respect yourself 
in the morning." The box is a closed openable container. In the box is a cake.

Instead of opening the box, say "The Wawa clerks frown on the consumption of unpurchased foodstuffs."


The can of root beer is a closed openable container carried by the player.

After shaking the can of root beer:
	say "You give the can a good hard shake."

Instead of listening to the can: say "It sounds [if we have shaken the can]fizzy[otherwise]calm[end 
if]!"

The sticky mess is fixed in place. "There is a sticky mess on the ground."

Instead of opening the can of root beer when we have shaken the can:
	remove the can of root beer from play;
	now the sticky mess is in the location;
	say "You open the can and fizzing sweet soda goes absolutely everywhere."
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0001092)
EmacsUser (manager)
2011-03-15 16:19

One other thing here is that ``shaking'' is not automatically mapped to ``shak,'' but rather ``shake'' because of the understand line. Perhaps the bug here should be that the mapping between WI 12.8 and Example 193 needs to made clearer, with the suggestion to include ``shaken'' being one way that clarity might be improved.

If that sounds okay, I can confirm.
(0001096)
otistdog (reporter)
2011-03-17 14:40
edited on: 2011-03-17 14:41

I'll try to be clearer: In the existing example 193, the "shake" verb is created with a custom past participle "shaken". However, outside the initial declaration, the past participle is not used in the example at all, which makes it seem pointless.

The included alternate version of the example makes use of a "when we have shaken" construction (see last block) which is automatically made available in response to creating the custom past participle; this seemed a better illustration of the point of the associated chapter.

(I see this issue was automatically changed back to "new". I don't have a problem with the "feedback" designation -- just wanted to make sure that the reason for my submission was clear.)

(0001101)
EmacsUser (manager)
2011-03-21 13:55

Sorry, I didn't see that the custom past participle was already in 193. Confirmed. Also, changed WI 12.18 to WI 12.8 in the description.
(0001102)
EmacsUser (manager)
2011-03-21 13:55

...and corrected a typo.

- Issue History
Date Modified Username Field Change
2011-02-12 20:32 otistdog New Issue
2011-03-15 16:19 EmacsUser Note Added: 0001092
2011-03-15 16:19 EmacsUser Status new => feedback
2011-03-15 16:19 EmacsUser Summary Example 193 "3 AM" does not illustrate key points of section it is paired with, WWI 12.18 Irregular English Verbs => The connection between WI 12.8 Irregular English Verbs and Example 193 "3 AM" is unclear
2011-03-17 14:40 otistdog Note Added: 0001096
2011-03-17 14:40 otistdog Status feedback => new
2011-03-17 14:41 otistdog Note Edited: 0001096 View Revisions
2011-03-21 13:55 EmacsUser Note Added: 0001101
2011-03-21 13:55 EmacsUser Status new => confirmed
2011-03-21 13:55 EmacsUser Category The Recipe Book => Examples
2011-03-21 13:55 EmacsUser Summary The connection between WI 12.8 Irregular English Verbs and Example 193 "3 AM" is unclear => Example 193, "3 AM", illustrate the creation, but not the use of a custom past participle
2011-03-21 13:55 EmacsUser Description Updated View Revisions
2011-03-21 13:55 EmacsUser Note Added: 0001102
2011-03-21 13:55 EmacsUser Summary Example 193, "3 AM", illustrate the creation, but not the use of a custom past participle => Example 193, "3 AM", illustrates the creation, but not the use of a custom past participle
2011-05-17 13:34 emshort Assigned To => graham
2011-05-17 13:34 emshort Status confirmed => assigned
2011-05-17 13:34 emshort Status assigned => resolved
2011-05-17 13:34 emshort Resolution open => fixed
2014-05-07 07:37 jmcgrew Fixed in Version => 6L02
2014-05-07 07:38 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker