Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000552Documentation, Examples, and Web SiteWriting with Informpublic2011-02-11 15:092014-05-07 07:38
Reporterpaulobrian 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSWindowsOS Version7
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000552: Chapter 4.13 (Duplicates) seems to be out of date
DescriptionA couple of statements in chapter 4.13 seem to be incorrect.

First: "(The player has to type numbers as words when counting things here: so TAKE SIX TRIANGLES makes sense to Inform but TAKE 6 TRIANGLES doesn't, largely for traditional reasons.)" Having attempted TAKE 6 TRIANGLES in the game below, it seems to work fine now.

Second: "If there are very many items in the same place, commands like TAKE ALL and DROP ALL may mysteriously not quite deal with all of them - this is because the parser, the run-time program which deciphers typed commands, has only limited memory to hold the possibilities. It can be raised with a use option like so:

Use maximum things understood at once of 200."

When I uncomment "Use maximum things understood at once of 200." from the source below, I get the following error:

"Problem. You wrote 'Use maximum things understood at once of 200' : but that isn't a 'Use' option known to me, and needs to be one of the ones listed in the documentation."
Minimal Source Text To Reproduce
"Polygons"

A shape is a kind of thing. A triangle is a kind of shape.

The Geometry Lab is a room. 

In the Lab are 75 triangles. 

[Use maximum things understood at once of 200. ]
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0001020)
EmacsUser (manager)
2011-02-13 21:04

Confirmed. The limit-raising line should read

- - - -
Use maximum things understood at once of at least 200.
- - - -

- Issue History
Date Modified Username Field Change
2011-02-11 15:09 paulobrian New Issue
2011-02-12 18:45 jmcgrew Status new => acknowledged
2011-02-13 21:04 EmacsUser Note Added: 0001020
2011-02-13 21:04 EmacsUser Status acknowledged => confirmed
2011-05-17 13:08 emshort Assigned To => graham
2011-05-17 13:08 emshort Status confirmed => resolved
2011-05-17 13:08 emshort Resolution open => fixed
2014-05-07 07:37 jmcgrew Fixed in Version => 6L02
2014-05-07 07:38 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker