Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000054Core InformIndexingpublic2010-06-17 14:092010-07-01 23:07
ReporterRon Newcomb 
Assigned Tograham 
PrioritynormalSeveritycosmeticReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version6E59 
Target VersionFixed in Version6E72 
Summary0000054: seven minor scene index quibbles
Description#1
If the first scene of the story begins "when play begins", then the scene isn't connected to The Entire Game via the yellow plus icon, but rather, the Entire Game is listed at the bottom with a green question mark, and looks like it is divorced from, well, everything. But if the first scene begins "when the entire game begins", then the Entire Game is correctly tied via the yellow plus.

It is worth mentioning that the special phrasings in scene assertions "when play begins/ends" was introduced many builds before the default scene The Entire Game debuted. I would like to recommend that those assertions be re-implemented as syntactic sugar for "when the entire game begins/ends." It would solve the above issue, as well as the following one...

#2
Compiler rejects "My final scene ends when play ends." with an appropriate error message, and, this leaves the final scene to appear in the index as "never ends". These two issues do not happen with "My final scene ends when the entire game ends."

Again, if "when play begins/ends" were implemented as syntactic sugar for "when the entire game begins/ends", these problems would also disappear.


#3
The outline-map first lists scenes that are daisy-chained together, then lists scenes that begin on some condition. But if a scene can begin in two ways -- one by daisy-chain and one by some condition -- the scene is re-listed in the some-condition section without it's green question mark icon. (It is correctly italicized, however.)
Since the green question icon appears with the scene in the daisy-chain section, I believe the second listing is not necessary.

#4
The outline's legend explaining what the icons mean does not explain that an italicized scene name means it was listed earlier in the outline.

#5
The topmost gray box (the one with the mosaic icon) needs to mention & link to the remaining sections on the page, "General rules", "scene-changing machinery" & the scheduled events section.

#6
The two subheadings within the scheduled events section, "Timetable" and "Events with no specific time", each need the round blue icon that links to section 9.11 in the manual.

#7
Finally, the second, big section called "details of each scene" should be moved to last on the page. For any sizeable work, the details for a given scene will be jumped to via the handy gray magnifying-glass icons in the outline. The section is a bit too big for hunt & scroll. Secondly, due to its size it tends to "hide" the Rulebook and Scheduled Events sections that come after. May I recommend that the Scheduled Events section(s) come second (since it is blessedly short section even with a dozen items in it), followed by the rulebooks section(s), with the scene details appearing last?


(I beg to note that I am already very grateful for the recent changes!)
Minimal Source Text To Reproduce
"test" by Ron Newcomb

There is room. 

Scene 1 is a scene. 
Scene 1 begins when play begins. 
[Scene 1 begins when the entire game begins.]  [though more verbose, this looks better in the index]

Scene 1 ends when we have waited twice.   

Scene 2 is a scene. 
Scene 2 begins when scene 1 ends. 
Scene 2 ends when we have waited thrice.

Scene 3 is a scene. 
Scene 3 begins when scene 2 ends. 
[Scene 3 ends when play ends.] [Problem message, intentionally]
Scene 3 ends when the entire game ends.  [works nicely]

Scene 2 begins when the player's command includes "debug scene 2".

Carry out waiting: I press pause in 4 turns from now.
At the time when I press pause: say "Pause."

At 5 PM: say "Quitting time!"
TagsNo tags attached.
Effect(cosmetic) Index is created incorrectly
Attached Files

- Relationships

-  Notes
(0000025)
graham (administrator)
2010-06-17 15:36

This is a completely sensible posting, but since this forum is so new, I think it's worth pointing out that it refers to seven different issues, of which only #3 is arguably a bug; the rest are (useful) suggestions - which we have a separate forum for. We probably shouldn't use the bug tracker for general feedback about useful improvements, etc., but for honest-to-goodness bugs.

However:

#1 and #2 are based on a slight misunderstanding, I think. "S begins when play begins" and "S begins when Entire Game begins" are quite different in meaning, because Entire Game can end and then begin again if the player is given a second chance - as in old-school cave adventure games; where the "resume the story" phrase is used in the source.

#3, #4, #5, #6, #7 have all been acted on for the next build.

- Issue History
Date Modified Username Field Change
2010-06-17 14:09 Ron Newcomb New Issue
2010-06-17 15:06 jmcgrew Severity mild => cosmetic
2010-06-17 15:06 jmcgrew Status new => acknowledged
2010-06-17 15:36 graham Note Added: 0000025
2010-06-17 15:36 graham Status acknowledged => resolved
2010-06-17 15:36 graham Resolution open => fixed
2010-06-17 15:36 graham Assigned To => graham
2010-06-30 18:07 jmcgrew Fixed in Version => 6E72
2010-07-01 23:07 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker