Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000537Core InformRules and rulebookspublic2011-02-05 21:482014-05-07 07:35
Reportertustin2121 
Assigned Tograham 
PrioritynormalSeverityseriousReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSWindowsOS Version7
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000537: I am unable to create '<no text>'
DescriptionA very unhelpful problem message appears if you make a table that defines a value and adds a rule as its property. The source text provided in particular provides this problem message (with no link to the line of source text, I might add):

-------------
I am unable to create '<no text>' with the kind of value 'a values based rule producing values', because this is a kind of value which is not allowed as something to be stored in properties, variables and the like. (See the Kinds index for which kinds of value are available. The ones which aren't available are really for internal use by Inform.)
-------------

Removing the table rows with no value set in the rule column is not much better, producing this problem message (also with no line link):

-------------
I am unable to create the property 'turn rule', because it has too vague a kind ('a values based rule producing values'). I need to know exactly what kind of value goes into each property: for instance, it's not enough to say 'A door has a list of values called the access list', because I don't know what the entries in this list would have to be - 'A door has a list of people called the access list' would be better.
-------------

I believe this is indeed valid code, I have placed rules into tables before. Since the change in rule structure, perhaps this has changed, but the problem text gives no indication if this is the case. Also translating '<no text>' seems like a very serious problem. Finally, what type is a rule defined as "This is the (name) rule: rule succeeds."?
Minimal Source Text To Reproduce
A behavior is a kind of value. The behavior are defined by the Table of Behaviors.

Table of Behaviors
behavior		turn rule
Aimless			a rule
Happy			--
Sad			--
Suffering mildly 	interesting rule

This is the interesting rule:
	rule succeeds.

The Lane is a room.
Additional InformationThis has also been tried on Mac OSX 10.6
TagsNo tags attached.
Effect(serious) Compiler rejects valid code
Attached Files

- Relationships

-  Notes
(0000991)
tustin2121 (reporter)
2011-02-05 21:58

Possibly loosely related to problem 0000446 (and it's related bugs)? Inform seems to be trying to set the type at the most restrictive possible, and it failing to do so.
(0000995)
EmacsUser (manager)
2011-02-08 10:32

Confirmed. Rewriting with a parenthetical kind and the information in WI 18.12, the source text

- - - -
A behavior is a kind of value. The behaviors are defined by the Table of Behaviors.

Table of Behaviors
behavior    turn rule (an action based rule producing nothing)
Aimless    the little-used do nothing rule
Happy    the little-used do nothing rule
Sad    the little-used do nothing rule
Suffering mildly     interesting rule

This is the interesting rule:
    rule succeeds.

The Lane is a room.
- - - -

is accepted.
(0002283)
graham (administrator)
2014-01-12 14:22

Various deficiencies in problem messages have also been put right, but the underlying issue is also fixed, by means of a special exemption for table columns with rules in.

- Issue History
Date Modified Username Field Change
2011-02-05 21:48 tustin2121 New Issue
2011-02-05 21:58 tustin2121 Note Added: 0000991
2011-02-05 21:58 tustin2121 Issue Monitored: tustin2121
2011-02-07 19:16 jmcgrew Status new => acknowledged
2011-02-08 10:32 EmacsUser Note Added: 0000995
2011-02-08 10:32 EmacsUser Status acknowledged => confirmed
2011-02-28 13:57 jmcgrew Severity mild => serious
2014-01-12 14:22 graham Note Added: 0002283
2014-01-12 14:22 graham Status confirmed => resolved
2014-01-12 14:22 graham Resolution open => fixed
2014-01-12 14:22 graham Assigned To => graham
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:35 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker