Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000053Windows Inform application[IDEs] User Interfacepublic2010-06-17 14:072010-10-29 09:20
Assigned ToDavidK 
Platformx86OSWindowsOS VersionVista
Product Version6E59 
Target VersionFixed in Version6F95 
Summary0000053: Source code links don't bring the highlighted paragraphs into view
DescriptionSuppose the source text pane is centered somewhere in the
upper half of the source. A link in the index is clicked,
highlighting a paragraph at the end of the source. The pane
scrolls to bring the paragraph into view, but the problem
is that it doesn't scroll far enough, so the paragraph
remains out of view.
Minimal Source Text To Reproduce
[many many empty lines go here]

X is a room.
Additional InformationSteps to reproduce:

1. Start Inform
2. Click on ``Start a new project...''
3. Enter a file and author name
4. Click on ``Start''
5. Enter the minimal source
6. Scroll to the top
7. Place the cursor at the beginning of the first line
8. Click on ``Go!''
9. Click on the ``Index'' tab
10. Click on the ``World'' sub-tab
11. Click on the link for X
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
EmacsUser (manager)
2010-06-17 19:53

fundin: If you have an example that shows this behavior when the paragraph is shorter than the source pane, that would be nice. As I noted in additional information, I couldn't find such an example.
fundin (reporter)
2010-06-20 06:07

The size of the paragraph didn't matter over here (replacing all those rooms with a single one gives the same result), but it seems like the paragraph needs to be pretty close to the end of the source for this to happen. If I make ten consecutive paragraphs each defining a room, then only the last nine will not be scrolled into view.
EmacsUser (manager)
2010-06-20 14:51

Confirmed (this time as reported), also on XP. At the time I first confirmed this I was trying to get through the outstanding OS X bugs, and I mistakenly read this one as applying to that IDE.

Also, any IDE can only be expected to get the right paragraph, because each paragraph is a single line in a .ni file, and the compiler only reports line numbers, not column numbers. So my misinterpretation was unfair, and I won't open a bug against the OS X IDE.
fundin (reporter)
2010-06-21 15:09

I should like to add that the same problem also occurs in the documentation tab when highlighting search results.

- Issue History
Date Modified Username Field Change
2010-06-17 14:07 fundin New Issue
2010-06-17 15:15 jmcgrew Status new => acknowledged
2010-06-17 18:50 EmacsUser Note Added: 0000027
2010-06-17 18:50 EmacsUser Status acknowledged => feedback
2010-06-17 18:52 EmacsUser Note Deleted: 0000027
2010-06-17 18:59 EmacsUser Status feedback => acknowledged
2010-06-17 19:53 EmacsUser Note Added: 0000029
2010-06-17 19:53 EmacsUser Status acknowledged => confirmed
2010-06-17 19:53 EmacsUser Steps to Reproduce Updated View Revisions
2010-06-17 19:53 EmacsUser Additional Information Updated View Revisions
2010-06-20 06:07 fundin Note Added: 0000076
2010-06-20 07:31 graham Assigned To => DavidK
2010-06-20 07:31 graham Status confirmed => assigned
2010-06-20 14:51 EmacsUser Note Added: 0000098
2010-06-20 14:51 EmacsUser Steps to Reproduce Updated View Revisions
2010-06-20 14:51 EmacsUser Additional Information Updated View Revisions
2010-06-21 15:09 fundin Note Added: 0000107
2010-07-02 00:06 jmcgrew Product Version => 6E59
2010-10-03 02:32 DavidK Status assigned => resolved
2010-10-03 02:32 DavidK Resolution open => fixed
2010-10-29 09:20 jmcgrew Fixed in Version => 6F95
2010-10-29 09:20 jmcgrew Status resolved => closed

Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker