Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000527Core InformModel worldpublic2011-01-29 22:502014-05-07 07:33
ReporterChrisC 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSWindowsOS Version7
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000527: "<room> is <a kind of room> above/below <room>" does not properly create connections between rooms
DescriptionInstead of Maze 5 being mapped above Maze 6 as it should be, Maze 5 is created with a down connection to Maze 6, and Maze 6 is created with no connection at all to Maze 5. I originally discovered this using a kind of room called a "mazing room", but "a room" also causes this misbehavior.
Minimal Source Text To Reproduce
Maze 6 is a room. 

Maze 5 is a room above Maze 6.
Additional InformationCommenting out "a room" on the second line causes the correct connections to be made.
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships

-  Notes
(0000985)
EmacsUser (manager)
2011-02-01 15:58

Confirmed, with a small clarification.
(0000989)
ChrisC (reporter)
2011-02-03 20:02

Interestingly, a similar problem happens with doors:

Top of Small Pit is a room. The rough stone steps are a door[. They are] below the Top of Small Pit.

Without uncommenting to split that sentence in two, the map connection is not made.
(0002497)
graham (administrator)
2014-02-15 02:22

I've thought about this for a while now, but have decided to leave it as it stands, because a change would help some authors but hinder others. I've instead added the following to the documentation:

"Finally, note that Inform's assumptions about two-way directions are only applied to simple sentences. When the source text seems to be saying something complicated, Inform takes it as a precise description of what's wanted. So, for example, in:

The Attic is above the Parlour.
The Attic is a dark room above the Parlour.

Inform makes guesses about the first sentence, and makes a two-way connection; but it accepts the second sentence more precisely, with just a one-way connection."

- Issue History
Date Modified Username Field Change
2011-01-29 22:50 ChrisC New Issue
2011-01-30 13:55 jmcgrew Status new => acknowledged
2011-02-01 15:58 EmacsUser Note Added: 0000985
2011-02-01 15:58 EmacsUser Status acknowledged => confirmed
2011-02-01 15:58 EmacsUser Additional Information Updated View Revisions
2011-02-03 20:02 ChrisC Note Added: 0000989
2014-02-15 02:22 graham Note Added: 0002497
2014-02-15 02:22 graham Status confirmed => resolved
2014-02-15 02:22 graham Resolution open => fixed
2014-02-15 02:22 graham Assigned To => graham
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker