Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000520Documentation, Examples, and Web SiteWriting with Informpublic2011-01-27 15:102014-05-07 07:38
ReporterRon Newcomb 
Assigned Tograham 
Platformx86OSWindowsOS VersionXP
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000520: Missing detail in Section 2.6
DescriptionSection 2.6 states, "Finally, headings are used when working out what a name refers to. Suppose the source contains both a "four-poster bed" and also a "camp bed", and we write something like "The pillow is on the bed." Inform decides which bed is meant by giving priority to whichever is defined in the current section, or failing that the current chapter, or current part, or current book, or finally the current volume. This allows us to write, for instance,

   The four-poster bed is in the Boudoir. The pillow is on the bed.

and not have the pillow mysteriously turn up on the camp bed, which hasn't been mentioned since way back in Chapter 2."

...but that isn't fully correct. In the source code below, the pillow's line comes before the 2nd bed's line, so the pillow is placed on a bed from a different section. The docs might want to mention that minor detail, cause it can cause some confusion especially when an author starts shuffling around his furniture early in the design/coding phase of a game.

(This bug might have been reported by Aaron Reed a long time ago, right around Blue Lacuna's release.)
Minimal Source Text To Reproduce

Section 1 - foo

The buduoir is a room. The four-poster bed is a supporter, here. 

Section 2 - bar

A pillow is on the bed.

The guest room is a room. The guest bed is a supporter, here. 
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2011-01-27 15:10 Ron Newcomb New Issue
2011-01-28 19:02 jmcgrew Status new => acknowledged
2011-02-01 15:53 EmacsUser Status acknowledged => confirmed
2011-05-17 13:22 emshort Assigned To => graham
2011-05-17 13:22 emshort Status confirmed => resolved
2011-05-17 13:22 emshort Resolution open => fixed
2014-05-07 07:37 jmcgrew Fixed in Version => 6L02
2014-05-07 07:38 jmcgrew Status resolved => closed

Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker