Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000512Core InformRules and rulebookspublic2011-01-19 17:582014-05-07 07:35
ReporterRon Newcomb 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
PlatformPPCOSMac OS XOS Version10.4
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000512: Instead rules, which fail, do not set "the reason the action failed", blaming the Procedural rulebook
DescriptionThe summary says it all, really. Transcript below.
Minimal Source Text To Reproduce
There is room.

Instead of examining yourself (this is the standard instead rule), say "Try again."

Every turn, say "Failed the [reason the action failed]."

Test me with "x me / z / take me / x me"
Additional Information

insteadofsuccess
An Interactive Fiction by Ron Newcomb
Release 1 / Serial number 110119 / Inform 7 build 6G60 (I6/v6.32 lib 6/12N) SD

room

>x me
Try again.

Failed the Procedural rulebook.

>z
Time passes.

Failed the Procedural rulebook.

>x me
Try again.

Failed the Procedural rulebook.

>take me
You are always self-possessed.

Failed the can't take yourself rule.

>x me
Try again.

Failed the Procedural rulebook.
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships

-  Notes
(0000975)
EmacsUser (manager)
2011-01-21 09:43

Confirmed, but I'm not sure how to file this. In WI 12.5 where the phrase ``the reason the action failed'' first appears, the documentation consistently deals with the check rulebook only. But WI 12.4 gives examples of failed actions that use the instead rulebook.
(0001497)
graham (administrator)
2011-12-17 16:46

It's very arguable that this is undefined behaviour anyway, but fixed.

- Issue History
Date Modified Username Field Change
2011-01-19 17:58 Ron Newcomb New Issue
2011-01-20 02:37 jmcgrew Status new => acknowledged
2011-01-21 09:43 EmacsUser Note Added: 0000975
2011-01-21 09:43 EmacsUser Status acknowledged => confirmed
2011-12-17 16:46 graham Note Added: 0001497
2011-12-17 16:46 graham Status confirmed => resolved
2011-12-17 16:46 graham Resolution open => fixed
2011-12-17 16:46 graham Assigned To => graham
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:35 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker