Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000508Documentation, Examples, and Web SiteWriting with Informpublic2011-01-16 15:362014-05-07 07:38
ReporterPoster 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.5
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000508: The method for choosing the default starting room is not well-documented
DescriptionThe documentation (3.9) does not state that the first room in the backdrop determines where play begins.

"backdrop is in X, Y, and Z" is NOT THE SAME as "X is a room" from the perspective of the human writer/programmer, or from the perspective of the documentation.
Minimal Source Text To Reproduce
The floor is a backdrop. Floor is in Urinal Mint City.
	
Defecatory is a room. 
North from Defecatory is Urinal Mint City.

Urinal Mint City is a room.  
South from Urinal Mint City is Defecatory.
TagsNo tags attached.
Attached Files

- Relationships
related to 0000507closedjmcgrew Core Inform The first room listed in a backdrop is the room in which play begins 

-  Notes
(0000971)
jmcgrew (administrator)
2011-01-17 01:09
edited on: 2011-01-17 01:13

This isn't particular to backdrops - the player starts by default in the first room defined by any assertion (although "the player is in X" overrides this). For example:

<code>
Ownership relates one person to various rooms. The verb to own (he owns) implies the ownership relation.

Dr Evil owns Evil Lair.

Austin's Pad is a room.
</code>

The player will start in Evil Lair instead of Austin's Pad because Evil Lair was created first, by the assertion "Dr Evil owns Evil Lair". That assertion implies that Dr Evil and Evil Lair must exist, and Inform can guess their kinds from the definition of "to own". Likewise, "Floor is in Urinal Mint City" implies that Urinal Mint City must exist, and Inform guesses that it's a room, making it the first room created.

This whole process and how it relates to the player start could stand to be explained better. Perhaps in 3.2 ("Rooms and the map"), which comes close in the notes for the "Port Royal 1" example. 4.11 ("Default values of kinds") might also be relevant.


- Issue History
Date Modified Username Field Change
2011-01-16 15:36 Poster New Issue
2011-01-17 00:36 jmcgrew Relationship added related to 0000507
2011-01-17 01:09 jmcgrew Note Added: 0000971
2011-01-17 01:09 jmcgrew Severity serious => mild
2011-01-17 01:09 jmcgrew Summary Game does not begin in first room defined when using a backdrop. => The method for choosing the default starting room is not well-documented
2011-01-17 01:09 jmcgrew Status new => confirmed
2011-01-17 01:13 jmcgrew Note Edited: 0000971 View Revisions
2011-05-17 13:01 emshort Assigned To => graham
2011-05-17 13:01 emshort Status confirmed => resolved
2011-05-17 13:01 emshort Resolution open => fixed
2014-05-07 07:37 jmcgrew Fixed in Version => 6L02
2014-05-07 07:38 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker