Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000506Core InformActionspublic2011-01-12 16:532014-05-07 07:33
ReporterRon Newcomb 
Assigned Tograham 
PrioritynormalSeverityseriousReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSWindowsOS VersionXP
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000506: TAKE action fake-succeeds, doesn't run any of its rules, blames a "convert" check rule.
DescriptionThis is weird. The command is DAPHNE, ASK ME FOR BRENNA. Persuasion succeeds, so the action becomes Daphne asking the player for Brenna. Both the "asking yourself for something rule" and the "translate asking-for to giving rule" apply, the action becoming (the player) giving Brenna to Daphne, which does an implicit TAKE BRENNA, which has the bug: absolutely no check taking, carry out taking, or report taking rules apply. "Taking Brenna" succeeds... without having actually taken her (let alone tripping the can't take people rule). Finally, giving Brenna to Daphne only fails because of a carrying requirement rule.

Oh, and the "translate asking for to giving rule" is blamed for the whole affair.
Minimal Source Text To Reproduce
"test" by Ron Newcomb

There is room.
Brenna and Daphne are women, here. 
Persuasion: rule succeeds. 
Unsuccessful attempt by: say "[The actor] couldn't do that because of the [reason the action failed]."


Test me with "Rules all /  Actions /  Daphne, ask me for Brenna".
Additional Information



test
An Interactive Fiction by Ron Newcomb
Release 1 / Serial number 110112 / Inform 7 build 6G60 (I6/v6.32 lib 6/12N) SD

room
You can see Brenna and Daphne here.

>test me
(Testing.)

>[1] rules all
Rules tracing now switched to "all". Type "rules off" to switch it off again.

>[2] actions
[Rule "standard set going variables rule" does not apply.]
[Rule "determine visibility ceiling rule" does not apply.]
[Rule "Setting action variables for exiting" does not apply.]
Actions listing on.

>[3] daphne, ask me for brenna
[Rule "standard set going variables rule" does not apply.]
[Rule "determine visibility ceiling rule" does not apply.]
[Rule "Setting action variables for exiting" does not apply.]
[asking Daphne to try asking yourself for Brenna]
[Rule "standard set going variables rule" does not apply.]
[Rule "determine visibility ceiling rule" does not apply.]
[Rule "Setting action variables for exiting" does not apply.]
[(1) Daphne asking yourself for Brenna]
[Rule "asking yourself for something rule" applies.]
[Rule "translate asking for to giving rule" applies.]
[Rule "standard set going variables rule" does not apply.]
[Rule "determine visibility ceiling rule" does not apply.]
[Rule "Setting action variables for exiting" does not apply.]
[(2) giving Brenna to Daphne]
(first taking Brenna)
[Rule "standard set going variables rule" does not apply.]
[Rule "determine visibility ceiling rule" does not apply.]
[Rule "Setting action variables for exiting" does not apply.]
[(3) taking Brenna - silently]
[Rule "can't take yourself rule" does not apply.]
[Rule "can't take other people rule" does not apply.]
[Rule "can't take component parts rule" does not apply.]
[Rule "can't take people's possessions rule" does not apply.]
[Rule "can't take items out of play rule" does not apply.]
[Rule "can't take what you're inside rule" does not apply.]
[Rule "can't take what's already taken rule" does not apply.]
[Rule "can't take scenery rule" does not apply.]
[Rule "can only take things rule" does not apply.]
[Rule "can't take what's fixed in place rule" does not apply.]
[Rule "use player's holdall to avoid exceeding carrying capacity rule" does not apply.]
[Rule "can't exceed carrying capacity rule" does not apply.]
[Rule "standard taking rule" does not apply.]
[(3) taking Brenna - silently - succeeded]
[(2) giving Brenna to Daphne - failed the carrying requirements rule]

[(1) Daphne asking yourself for Brenna - failed the translate asking for to giving rule]

Daphne couldn't do that because of the translate asking for to giving rule.
[asking Daphne to try asking yourself for Brenna - succeeded]

>
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships
has duplicate 0000937closed Command gives a blank reponse 

-  Notes
(0000969)
Ron Newcomb (reporter)
2011-01-13 11:39

The translate asking for to giving rule uses "To convert to request..." phrase to swap actor and noun. But in the above command's case, the new actor is now the player, so "request" isn't right. Since I6's convention is (IIRC) that act_requestor should be 0 (when actor = the player) or the player (when actor is anyone else), the convert phrase is probably breaking that assumption, giving the bizarre results later on: the player is both actor and act_requester.

That's just an educated guess, though.
(0002400)
graham (administrator)
2014-01-28 02:21

There were two different bugs in that one-line definition of "To convert to request...", both occurring only in this one circumstance. Fixed now. (To my chagrin, I find that the big actions test case, an awful source text called "Obedience", _did_ test this configuration, but that we misread its output.)

- Issue History
Date Modified Username Field Change
2011-01-12 16:53 Ron Newcomb New Issue
2011-01-12 20:27 jmcgrew Status new => acknowledged
2011-01-13 11:39 Ron Newcomb Note Added: 0000969
2011-01-14 16:02 EmacsUser Status acknowledged => confirmed
2012-06-22 14:59 EmacsUser Relationship added has duplicate 0000937
2014-01-28 02:21 graham Note Added: 0002400
2014-01-28 02:21 graham Status confirmed => resolved
2014-01-28 02:21 graham Resolution open => fixed
2014-01-28 02:21 graham Assigned To => graham
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker