Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000494Core InformIndexingpublic2011-01-07 10:462011-01-10 11:15
ReporterFuchsia tude 
Assigned To 
PrioritynormalSeveritycriticalReproducibilityalways
StatusclosedResolutionfixed 
Platform64-bitOSWindowsOS Version7
Product Version6F95 
Target VersionFixed in Version6G60 
Summary0000494: Massive CPU and memory usage when rooms in index map are positioned self-referentially
DescriptionMassive memory consumption and long delay when compiling or clicking on the Index - World tab when the source changes relative positions of rooms in a cycle. For example, the code below takes up 360MB of memory after clicking the Index - World tab, following a minute of computation:
Minimal Source Text To Reproduce
Ad is north from Bo.

Index map with Ad mapped south from Bo. Index map with Bo mapped northwest from Ad.
Additional InformationThe problem gets exponentially worse as more rooms are rearranged on the Index Map. But in fact, the following code refuses to compile at all, claiming lack of memory (on an 8 gig system!):

"Alpha is a room. Index map with Alpha mapped southeast from Alpha."

I realize it's a bit much to expect an interactive fiction IDE to solve the halting problem, but is it possible to identify cycles like this and stop compiling with a syntax error? I accidentally ran into this problem on a big map, and since I didn't realize what had happened I was pretty much forced to revert to an older project file to fix the problem.
Tagswrongeffect
Effect(critical) Compiler hangs
Attached Files

- Relationships

-  Notes
(0000946)
jmcgrew (administrator)
2011-01-07 18:38

Moving to Core Inform since the index generation is platform-independent.
(0000947)
Fuchsia tude (reporter)
2011-01-07 19:41

Whoops, I can't seem to reproduce it in 6G06. The index map overhaul seems to have corrected the issue. Sorry about not checking for a new release version before submitting this issue, I just downloaded 6F95 a couple weeks ago.
(0000948)
EmacsUser (manager)
2011-01-08 10:43

Confirmed in 6F95, and verified fixed in 6G06.

- Issue History
Date Modified Username Field Change
2011-01-07 10:46 Fuchsia tude New Issue
2011-01-07 18:34 jmcgrew Status new => acknowledged
2011-01-07 18:34 jmcgrew Project Windows Inform application => Core Inform
2011-01-07 18:38 jmcgrew Effect => (critical) Compiler hangs
2011-01-07 18:38 jmcgrew Note Added: 0000946
2011-01-07 18:38 jmcgrew Severity serious => critical
2011-01-07 18:38 jmcgrew Category User Interface => Indexing
2011-01-07 18:38 jmcgrew Tag Attached: wrongeffect
2011-01-07 19:41 Fuchsia tude Note Added: 0000947
2011-01-08 10:43 EmacsUser Note Added: 0000948
2011-01-08 10:43 EmacsUser Status acknowledged => resolved
2011-01-08 10:43 EmacsUser Resolution open => fixed
2011-01-08 10:43 EmacsUser Fixed in Version => 6G60
2011-01-10 11:15 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker