Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000484Core InformActionspublic2010-12-28 15:182014-05-07 07:35
Reporteremail 
Assigned Tograham 
PrioritynormalSeveritycriticalReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSWindowsOS Version
Product Version6G60 
Target VersionFixed in Version6L02 
Summary0000484: Compiler crashes (code 10) with test using custom past participle and a time reference
DescriptionThe code below crashes the compiler with this message:

Translating the Source - Failed
The application ran your source text through the Inform 7 compiler, as usual,
but the compiler unexpectedly failed. This should not happen even if your source
text is gibberish, so you may have uncovered a bug in the program.
When a program like the I7 compiler fails, it typically returns an error
number: this time, the number was 10, and that probably indicates that the
compiler failed to manage its data structures properly. Perhaps you created a
complicated situation on which it has not been fully tested.
Minimal Source Text To Reproduce
"Crash Causer" by "Otis T. Dog"

Understand "shake [something preferably held]" as shaking.

Shaking is an action with past participle shaken, applying to one carried thing.

Report shaking:
	say "Nothing results of your shaking [the noun]."

To decide whether (the shakee - a thing) has been shaken recently:
	if we have shaken the shakee for less than 5 turns, decide yes;
	decide no.

The Wawa is a room.
TagsNo tags attached.
Effect(critical) Compiler crashes
Attached Files

- Relationships
duplicate of 0000543closedgraham A rule that references a just-called name in a condition describing repetitions causes compiler to fail 

-  Notes
(0000933)
EmacsUser (manager)
2010-12-28 19:18

Confirmed:

Program received signal EXC_BAD_ACCESS, Could not access memory.
Reason: KERN_PROTECTION_FAILURE at address: 0x00000128
0x00082300 in Kinds__interpret_test_equality ()
(gdb) bt
#0 0x00082300 in Kinds__interpret_test_equality ()
#1 0x000d1882 in Calculus__Relations__Equality__compile ()
#2 0x000d1e38 in Semantics__BPs__get_i6_schema ()
#3 0x000d34f7 in i6_schema_of_atom ()
#4 0x000d389c in Calculus__Atoms__compile ()
#5 0x00109537 in Calculus__Deferrals__compile_test_of_proposition ()
#6 0x00109969 in Plugins__Actions__Patterns__compile_pattern_match_clause ()
#7 0x0010a122 in Plugins__Actions__Patterns__compile_pattern_match ()
#8 0x0010ab0b in Plugins__Actions__Patterns__compile_present_tense ()
#9 0x0010af18 in Code__Chronology__past_tenses_i6_escape ()
#10 0x0011e6bb in Config__Template__interpret ()
#11 0x00119a16 in Config__Template__interpret ()
#12 0x00119a16 in Config__Template__interpret ()
#13 0x001205ec in main ()
(0001322)
graham (administrator)
2011-10-07 11:23

This was indeed a duplicate of 0000543.

- Issue History
Date Modified Username Field Change
2010-12-28 15:18 jmcgrew New Issue
2010-12-28 15:18 jmcgrew Reporter jmcgrew => email
2010-12-28 15:19 jmcgrew Status new => acknowledged
2010-12-28 19:18 EmacsUser Note Added: 0000933
2010-12-28 19:18 EmacsUser Status acknowledged => confirmed
2011-02-09 15:47 EmacsUser Relationship added related to 0000543
2011-02-10 10:49 otistdog Issue Monitored: otistdog
2011-10-07 11:23 graham Note Added: 0001322
2011-10-07 11:23 graham Status confirmed => resolved
2011-10-07 11:23 graham Resolution open => fixed
2011-10-07 11:23 graham Assigned To => graham
2011-12-12 16:08 EmacsUser Relationship replaced duplicate of 0000543
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:35 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker