Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000446Core InformTablespublic2010-11-30 08:162014-05-07 07:35
Reporterektemple 
Assigned Tograham 
PrioritynormalSeverityseriousReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.6
Product Version6F95 
Target VersionFixed in Version6L02 
Summary0000446: Inform rejects kinds other than object, number, text, and indexed text in parenthetical table column typing
DescriptionIf you attempt to use a kind (other than object, number, text, and indexed text) parenthetically in a table column name, Inform rejects the attempt to type with this message:

"Brackets are only allowed in table column names when giving the kind of value which will be stored in the column. So 'poems (indexed text)' is legal, but not 'poems (chiefly lyrical)'."

Possibly this kind of typing is not allowed, but Table of Testing One shows that typing in the same way on a separate header line is accepted (but see report 0000444--this does not act as expected). More to the point, Inform *will* infer the type of the column as "person" if no attempt at explicit typing is made. (Again, see report 0000444.)
Minimal Source Text To Reproduce
Test is a room. There is a pen in Test.

Table of Testing One
subject
a person
yourself
--

Table of Testing Two
subject_ (a person)
yourself
--
TagsNo tags attached.
Effect(serious) Compiler rejects valid code
Attached Files

- Relationships
related to 0000444closedgraham Inform ignores explicit typing for table columns 
has duplicate 0000572closed A blank table with parenthetical kind definitions next to column titles for non-numeric, non-text kinds won't compile 

-  Notes
(0000871)
Ron Newcomb (reporter)
2010-11-30 10:21

Possibly related:

I submitted a bug report (long before Mantis existed) that when type was inferred from Bob, the column was set to type Man rather than Person. (Likewise for Janet: Woman rather than Person.) Since a person is almost always one or the other, a special case was added to infer Person rather than Man/Woman.
(0001209)
EmacsUser (manager)
2011-06-30 15:39

Adjusted the summary and description to incorporate information from 0000572.
(0001421)
graham (administrator)
2011-10-22 08:40

Fixed. The list of possibilities it accepted was actually broader than that, but you can now use any named kind here.

- Issue History
Date Modified Username Field Change
2010-11-30 08:16 ektemple New Issue
2010-11-30 09:03 jmcgrew Relationship added related to 0000444
2010-11-30 09:04 jmcgrew Severity mild => serious
2010-11-30 09:04 jmcgrew Reproducibility have not tried => always
2010-11-30 09:04 jmcgrew Status new => confirmed
2010-11-30 10:21 Ron Newcomb Note Added: 0000871
2011-06-30 15:39 EmacsUser Note Added: 0001209
2011-06-30 15:39 EmacsUser Summary Inform rejects subkinds of object in parenthetical table column typing => Inform rejects kinds other than object, number, text, and indexed text in parenthetical table column typing
2011-06-30 15:39 EmacsUser Description Updated View Revisions
2011-06-30 15:40 EmacsUser Relationship added has duplicate 0000572
2011-10-22 08:40 graham Note Added: 0001421
2011-10-22 08:40 graham Status confirmed => resolved
2011-10-22 08:40 graham Resolution open => fixed
2011-10-22 08:40 graham Assigned To => graham
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:35 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker