Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000434Core InformKinds and type checkingpublic2010-11-21 19:052014-05-07 07:33
ReporterPoster 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.5
Product Version6F95 
Target VersionFixed in Version6L02 
Summary0000434: Saying a kind "can be closed or open" makes "open" work strangely
DescriptionIf you declare a kind of supporter, then all open containers are closed. I've tested this with two containers and two rooms, so apparently it's system-wide. I've also rephrased the definition of the bowl by breaking up the declarations into separate declarations, and that makes no difference.
Minimal Source Text To Reproduce
A cardboard box is a kind of supporter. A cardboard box can be closed or open. A cardboard box can 
be openable. 

Sanitarium is a room.

The bowl is a transparent open container in Sanitarium. 
The burger is in the bowl.
Additional InformationHere is the output:
Welcome
An Interactive Fiction
Release 1 / Serial number 101121 / Inform 7 build 6F95 (I6/v6.31 lib 6/12N) SD

Sanitarium
You can see a bowl (closed) (in which is a burger) here.
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Files

- Relationships
has duplicate 0000498closedjmcgrew Creating an Open/Closed Thing Closes an Open Container Kind 

-  Notes
(0000865)
jmcgrew (administrator)
2010-11-21 19:31

The "showme" command refers to the box as a transparent closed container but later says it's open. If you make the bowl openable and then try to open it, you're told that it's already open.

The culprit seems to be the order of the terms when you say the box can be "closed or open". If you change it to "open or closed" (matching the Standard Rules definitions), things seem to work correctly.
(0002428)
graham (administrator)
2014-02-01 12:27

Fixed at last.

- Issue History
Date Modified Username Field Change
2010-11-21 19:05 Poster New Issue
2010-11-21 19:31 jmcgrew Note Added: 0000865
2010-11-21 19:31 jmcgrew Status new => confirmed
2010-11-21 19:31 jmcgrew Summary Declaring a Kind of Supporter Makes Containers Closed => Saying a kind "can be closed or open" makes "open" work strangely
2011-01-08 20:16 jmcgrew Relationship added has duplicate 0000498
2014-02-01 12:27 graham Note Added: 0002428
2014-02-01 12:27 graham Status confirmed => resolved
2014-02-01 12:27 graham Resolution open => fixed
2014-02-01 12:27 graham Assigned To => graham
2014-05-07 07:32 jmcgrew Fixed in Version => 6L02
2014-05-07 07:33 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker