Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000432Core InformModel worldpublic2010-11-21 08:262011-01-10 11:15
Reportermikegentry 
Assigned Tograham 
PrioritynormalSeveritycosmeticReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSWindowsOS Version7
Product Version6F95 
Target VersionFixed in Version6G60 
Summary0000432: "3-sided door" problem message does not provide source code link
DescriptionInform now generates a problem message if you try to create a door with more than two "sides". However, the message does not include any link to the source code.

Possibly this is intentional, because the compiler can't know which assertion about the door's exits is the extraneous one? If that is the case, then I would suggest that a link to the assertion that created the door would be the most helpful.
Minimal Source Text To Reproduce
Indoors is a room. Outdoors is a room. 

The screen door is a door. It is north of Indoors, south of Outdoors.

Outside from indoors is the screen door.
TagsNo tags attached.
Effect(cosmetic) Error message is badly worded
Attached Files

- Relationships

-  Notes
(0000861)
graham (administrator)
2010-11-21 15:36

The problem message now supplies links to all three map connections; the author can then choose which one to strike out.

- Issue History
Date Modified Username Field Change
2010-11-21 08:26 mikegentry New Issue
2010-11-21 12:08 jmcgrew Severity mild => cosmetic
2010-11-21 12:08 jmcgrew Status new => acknowledged
2010-11-21 12:44 EmacsUser Status acknowledged => confirmed
2010-11-21 15:36 graham Note Added: 0000861
2010-11-21 15:36 graham Status confirmed => resolved
2010-11-21 15:36 graham Resolution open => fixed
2010-11-21 15:36 graham Assigned To => graham
2010-12-23 17:37 jmcgrew Fixed in Version => 6G60
2011-01-10 11:15 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker