Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000043Core InformRelationspublic2010-06-16 07:142010-07-01 23:07
Reporterfundin 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSWindowsOS VersionVista
Product Version6E59 
Target VersionFixed in Version6E72 
Summary0000043: Confusion between one-to-various and various-to-various relations
DescriptionAlthough a various-to-one relation is intended in the example
source, I7 creates a various-to-various relation, and thus the
problem of double ownership is not being caught. Trying to use
the 'owner' property can cause internal errors in some
situations.
Minimal Source Text To Reproduce
Home is a room.

Pet ownership relates various animals to a person (called the
owner). The verb to be owned by implies the pet ownership
relation.

The zebra is owned by Bill.
The zebra is owned by Bob.
Additional InformationThe problem is that the declaration of pet ownership uses the
wording 'a person' rather than 'one person'. Previous versions did
not have a problem with this.
TagsNo tags attached.
Effect(mild) Compiler accepts invalid code
Attached Files

- Relationships

-  Notes
(0000072)
graham (administrator)
2010-06-20 04:58

Inform now assumes "one" if this is unspecified and either there is a called-name supplied (which implies uniqueness) or the other term is explicitly "various" (since then the absence of "various" is pointed). Both of those apply here, so the test case here now creates a V-to-1 relation and then throws a contradiction problem message, as expected.

- Issue History
Date Modified Username Field Change
2010-06-16 07:14 fundin New Issue
2010-06-16 08:03 jmcgrew Status new => acknowledged
2010-06-18 01:48 jmcgrew Status acknowledged => confirmed
2010-06-20 04:58 graham Note Added: 0000072
2010-06-20 04:58 graham Status confirmed => resolved
2010-06-20 04:58 graham Resolution open => fixed
2010-06-20 04:58 graham Assigned To => graham
2010-06-30 18:07 jmcgrew Fixed in Version => 6E72
2010-07-01 23:07 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker