Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000042Core InformRelationspublic2010-06-16 07:082010-07-01 23:07
Reporterfundin 
Assigned Tograham 
PrioritynormalSeverityseriousReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSWindowsOS VersionVista
Product Version6E59 
Target VersionFixed in Version6E72 
Summary0000042: Equivalence relations of values don't work (with solution)
DescriptionThe source results in a game which quits during startup without
printing anything.
Minimal Source Text To Reproduce
Home is a room.

Friendship relates various numbers to each other in groups. The
verb to be friends with implies the friendship relation.

6 is friends with 28.
28 is friends with 496.
30 is friends with 140.
80 is friends with 200.
40 is friends with 224.
Additional InformationThere are nine distinct numbers involved here. With eight or less,
everything works. (This is when compiling to Glulx, by the way.)
The problem seems to be that the relation data is stored in a
fixed-size array.

(The cause of this issue might be the same as in issue 41, but I'm
filing a separate report just in case.)
TagsNo tags attached.
Effect(serious/mild) Game compiles but misbehaves
Attached Filestxt file icon resize_dynamic_equivalence_relations.patch.txt [^] (1,410 bytes) 2010-06-18 00:38 [Show Content]

- Relationships

-  Notes
(0000037)
jmcgrew (administrator)
2010-06-18 00:41
edited on: 2010-06-18 00:41

Indeed, dynamic equivalence relations are not being reallocated when they get too full. The attached patch for RelationKind.i6t solves it.

(0000070)
graham (administrator)
2010-06-20 04:24

Jesse's patch passes the test suite, and I've applied it for the next build.

- Issue History
Date Modified Username Field Change
2010-06-16 07:08 fundin New Issue
2010-06-16 08:00 jmcgrew Severity mild => serious
2010-06-16 08:00 jmcgrew Status new => acknowledged
2010-06-16 12:05 jmcgrew Assigned To => jmcgrew
2010-06-16 12:05 jmcgrew Status acknowledged => confirmed
2010-06-17 23:01 jmcgrew Status confirmed => assigned
2010-06-18 00:38 jmcgrew File Added: resize_dynamic_equivalence_relations.patch.txt
2010-06-18 00:41 jmcgrew Note Added: 0000037
2010-06-18 00:41 jmcgrew Status assigned => confirmed
2010-06-18 00:41 jmcgrew Note Edited: 0000037 View Revisions
2010-06-20 01:26 jmcgrew Assigned To jmcgrew =>
2010-06-20 01:26 jmcgrew Summary Equivalence relations of values don't work => Equivalence relations of values don't work (with solution)
2010-06-20 01:26 jmcgrew Issue Monitored: jmcgrew
2010-06-20 04:24 graham Note Added: 0000070
2010-06-20 04:24 graham Status confirmed => resolved
2010-06-20 04:24 graham Resolution open => fixed
2010-06-20 04:24 graham Assigned To => graham
2010-06-30 18:07 jmcgrew Fixed in Version => 6E72
2010-07-01 23:07 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker