Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000412Core InformAssertions and creationspublic2010-11-14 09:422014-05-07 07:35
ReporterPoster 
Assigned Tograham 
PrioritynormalSeveritycosmeticReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.5
Product Version6F95 
Target VersionFixed in Version6L02 
Summary0000412: Spurious Semicolon Causes Wrong Error Message
DescriptionA spurious semicolon after a room description generates an error that treats a valid statement (the next line) as bogus. That is not only unhelpful, it's misleading because it makes people think that either the compiler is broken or the documentation is wrong. The effect of this is far beyond cosmetic.

A spurious end-of-statement character should be ignored, or it should generate an error reading something like this:

Problem. There is an end of statement character (a semicolon) but no statement preceding it.

---
Problem. The sentence 'Down from Refrigtop is Countertop' appears to say two things are the same - I am reading 'Down from Refrigtop' and 'Countertop' as two different things, and therefore it makes no sense to say that one is the other: it would be like saying that 'Poirot is Hastings'. It would be all right if the second thing were the name of a kind, perhaps with properties: for instance 'St Mary Mead is a lighted room' says that something called St Mary Mead exists and that it is a 'room', which is a kind I know about, combined with a property called 'lighted' which I also know about.
Minimal Source Text To Reproduce
Countertop is a room.
		
Refrigtop is a room. ".";
Down from Refrigtop is Countertop.
TagsNo tags attached.
Effect(cosmetic) Error message is badly worded
Attached Files

- Relationships

-  Notes
(0001389)
graham (administrator)
2011-10-16 06:18

The Down sentence was correctly handled, since the use of the upper case D in mid-sentence meant that Inform did not read it as a direction but as part of a proper noun. However, the lack of a problem for the spurious semicolon was arguably a bug, since I didn't intend this to be legal syntax; fixed.

- Issue History
Date Modified Username Field Change
2010-11-14 09:42 Poster New Issue
2010-11-14 10:18 jmcgrew Severity mild => cosmetic
2010-11-14 10:18 jmcgrew Status new => confirmed
2011-10-16 06:18 graham Note Added: 0001389
2011-10-16 06:18 graham Status confirmed => resolved
2011-10-16 06:18 graham Resolution open => fixed
2011-10-16 06:18 graham Assigned To => graham
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:35 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker