Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000041Core InformRelationspublic2010-06-16 07:022010-07-01 23:07
Reporterfundin 
Assigned Tograham 
PrioritynormalSeveritymildReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSWindowsOS VersionVista
Product Version6E59 
Target VersionFixed in Version6E72 
Summary0000041: Relations of values which involve a property don't work
DescriptionThe source text results in a run-time error:

*** Run-time problem P18: Tried to access property for a value
which didn't fit: if this were a number it would be 0.
Minimal Source Text To Reproduce
Home is a room.

Partnership relates one number to another (called the partner). The
verb to be partnered with implies the partnership relation.

5 is partnered with 7.

When play begins: showme the partner of 7.
Additional InformationNumbers can't normally have properties, so cases like these might
need special treatment.
TagsNo tags attached.
Effect(mild) Compiler accepts invalid code
Attached Files

- Relationships

-  Notes
(0000038)
jmcgrew (administrator)
2010-06-18 01:34

Confirmed. I believe this is a case of "compiler accepts invalid code", since it attempts to create a "partner" property for a kind of value that is not allowed to have properties.

"the number that relates to 7 by the partnership relation" works here instead, although it's read-only.
(0000073)
graham (administrator)
2010-06-20 05:11

Fixed. This now produces a more useful compile-time problem message.

- Issue History
Date Modified Username Field Change
2010-06-16 07:02 fundin New Issue
2010-06-16 08:03 jmcgrew Status new => acknowledged
2010-06-18 01:34 jmcgrew Effect (serious/mild) Game compiles but misbehaves => (mild) Compiler accepts invalid code
2010-06-18 01:34 jmcgrew Note Added: 0000038
2010-06-18 01:34 jmcgrew Status acknowledged => confirmed
2010-06-20 05:11 graham Note Added: 0000073
2010-06-20 05:11 graham Status confirmed => resolved
2010-06-20 05:11 graham Resolution open => fixed
2010-06-20 05:11 graham Assigned To => graham
2010-06-30 18:07 jmcgrew Fixed in Version => 6E72
2010-07-01 23:07 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker