Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000401Core InformActionspublic2010-11-08 05:512014-05-07 07:35
ReporterPhonatacid 
Assigned Tograham 
PrioritynormalSeverityseriousReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSMac OS XOS Version10.6
Product Version6F95 
Target VersionFixed in Version6L02 
Summary0000401: The ' (matched as "symbol") ' segment doesn't work with values that are not objects.
DescriptionStating that,

The Testing action has a number called the test number (matched as "number").


doesn't produce a compiler Problem, but using

Carry out Testing number 0:
__________etc...

does.


Minimal Source Text To Reproduce
There is a room.

Testing is an action applying to nothing.
The Testing action has a thing called the test thing (matched as "thing").
The Testing action has a number called the test number (matched as "number").

Carry out Testing thing the player:
	say "Testing the thing";
	
[Carry out Testing number 0:
	say "Testing the number";]
	
When play begins:
	try testing;
Additional InformationThis the message produced by the compiler

Problem. In the sentence 'Carry out Testing number 0' , it looks as if you intend '0' to involve a range of objects matching a description, but that would mean comparing two kinds of value which cannot mix - an object and a number - so this must be incorrect.
TagsNo tags attached.
Effect(serious) Compiler rejects valid code
Attached Files

- Relationships
has duplicate 0000736closed Non-object action variables cannot be referred to in shorthand rule definitions 

-  Notes
(0000802)
Ron Newcomb (reporter)
2010-11-08 10:39

A simplified test case, which also doesn't use a kind as a preposition(!)

----------------------------
There is a room.

The waiting action has a number called the test number (matched as "roughly").

Instead of waiting roughly 5, say "Waiting [test number] minutes."

When play begins, try waiting.
------------------------
(0000813)
EmacsUser (manager)
2010-11-13 07:06

Confirmed. Also, accepts invalid:

Carry out Testing number nothing:
    say "Testing the number";
(0002311)
graham (administrator)
2014-01-18 11:58

When this feature was introduced, I don't think anybody even thought about the possibility of a non-object kind here, but Inform has come along since then, and it's now no problem. Fixed.

- Issue History
Date Modified Username Field Change
2010-11-08 05:51 Phonatacid New Issue
2010-11-08 10:39 Ron Newcomb Note Added: 0000802
2010-11-08 14:56 jmcgrew Severity mild => serious
2010-11-08 14:56 jmcgrew Status new => acknowledged
2010-11-13 07:06 EmacsUser Note Added: 0000813
2010-11-13 07:06 EmacsUser Status acknowledged => confirmed
2014-01-14 13:04 EmacsUser Relationship added has duplicate 0000736
2014-01-18 11:58 graham Note Added: 0002311
2014-01-18 11:58 graham Status confirmed => resolved
2014-01-18 11:58 graham Resolution open => fixed
2014-01-18 11:58 graham Assigned To => graham
2014-05-07 07:34 jmcgrew Fixed in Version => 6L02
2014-05-07 07:35 jmcgrew Status resolved => closed


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker